Batman: Arkham Asylum GOTY Edition Cheats and Trainer for Steam

Batman: Arkham Asylum GOTY Edition
This is the official discussion topic of the Batman: Arkham Asylum GOTY Edition Trainer and Cheats in the WeMod app. Please post any suggestions, bug reports, or praise that you may have for the cheats in here!

Download Trainer

Download the trainer or find it in the WeMod app.

Trainer Options and Cheats:

1. Unlimited Health
2. Unlimited Upgrade Points
3. Easy Kills
4. Max Combo
5. Player Speed


Supported Game Versions:

We strive to keep our trainers up to date with the latest game versions. WeMod automatically detects which version you have installed and activates the mods accordingly. So there’s no need to worry about which version of the game you have!

Updates and Changes:

  • 08/02/2019
    Started development

  • 08/04/2019
    Released trainer with 5 cheats

Like what you see?

Check out all of the games WeMod supports here.


The Batman: Arkham Asylum Game of the Year Edition cheats have been updated!


  • Released trainer with 5 cheats

Please post in this topic if you run into any issues!


it’s gonna be any version that works on the epic games launcher?


I downloaded the game from the Steam store but when I try to play it it keeps saying ‘We’re having trouble starting or finding your opened game’ what do I do to fix this?

1 Like

I get the same problem with the Epic games version. I even drug the game .exe into the trainer and it still can’t find the game. It can start the game, but can’t find it. So far I haven’t been able to get any trainers here that work.

Another thing, why are the so darn big too? 5 options and it takes up almost my whole screen @ 1080x1920. That’s way too big if you ask me. It’s nice looking, just too darn big. Make them 600x400. That would be much better to work with.

1 Like

Hello wemod trainer does not work

1 Like

STN, the Max combo cheat (F4) causes a black void room glitch. When you enter a room, the only thing visible is Batman and a bit of floor. If you go further, you’ll fall into the void and even if you restart checkpoint or restart the game entirely, you’ll still be stuck falling. Had to start a new game because of it.

1 Like

Hello and welcome to the WeMod community @AIGT22. :slight_smile:

I did not experience this issue when I played the game a few months back. It’s also quite unlikely for a trainer to cause visual glitches in a game because trainers actually do not touch the game in any way at all, they just alter memory values in the RAM of your PC.

Please go to your Steam library and verify the game’s files. Visual glitches are often the result of corrupted files or files that didn’t download correctly. Here’s how to do that:

Also, turn off the maximum combo cheat when you don’t actually need it (ie - when you’re not fighting). It’s possible that the glitch is caused by the game being extremely confused about which graphics to load, because you’re not actually supposed to have the combo meter on the screen since you’re not in combat.

1 Like

Can replicate the issue AllInGoodTime is experiencing. The combo glitch seems to multiply not only the combo stat, but the game completion percentage. Currently, the game says its 2061% complete, and I’m stuck in the black room glitch with my only save.

Right now everything works besides the unlimited upgrade points
any fix for that?

1 Like

What’s the path to the game.exe. every one I tried opens the launcher but then I have to select Play to launch the game which then does not allow me to select any of the WeMod cheats?

Thanks in advance

1 Like

I’m facing an issue with my version. I have latest version of Wemod. When I launch my game it starts without any issue. The game’s launcher popsup and when I click play on it, the main game launches, and as soon as game launches, according to Wemod, my game get’s closed. So, because of this, I’m unable to use cheats in this game. If anyone knows how to fix this issue, please help.

1 Like

Just wondering if you ever got it fixed, only realised too late it was the trainer that was bugging the game out and I’ve already restarted twice, this time I was 2/3 of the way through and I really don’t want to do it again?

For this to work for epic, you have to chose the ShippingPC-BmGame.exe this opens the game directly, skipping the launcher.

Cheats are not working on Steam version as of today’s date 03/26/22.
I just met Wemod and subscribed to PRO to play Batman Arkham Asylum and it is not working.
Could you try to help with this? Please


Having the same issue as well.
Thank you for your time

1 Like

Is there any way this could get a noclip/fly cheat added? I came across a falling out of the map bug when entering a new location. It was a scarecrow encounter flashback to Wayne Manor and after entering the location I am stuck in a checkpoint freefall loop. Anything else I have found online suggests altering game files or using cheat engine.

Does not work every time regardless of whether I start the game with Wii mod or I start it and then open wemod when I go to add skill points I can add the points and then when I go back to play he stands at like a scarecrow unable to move impossible to play the game once I activate the mod

Batman Collection was on sale on steam today…and Wemod has cheats…that was the only reason i bought it and I’m a WEmod pro subscriber…so disappointed…2nd game in my collection that wemod does not work…may have worked in the past…but today 9/29/2022? uhh no…when you use mods…batman can no longer move…please advise?


Im having the same issue, whenever i disable wemod and open it normally everythings fine. But if i use Wemod, Batman just tposes and wont move. Idk why its happening and ive tried everything