Blasphemous Cheats and Trainer for Steam

This is the official discussion topic of the Blasphemous Trainer and Cheats in the WeMod app. Please post any suggestions, bug reports, or praise that you may have for the cheats in here!

Download Trainer

Download the trainer or find it in the WeMod app.

Trainer Options and Cheats:

1. Unlimited Health
2. Unlimited Fervour
3. Unlimited Flasks
4. Max Beads Slots
5. No Skill Cooldown
6. Set Tears of Atonement
7. Set Damage Multiplier
8. Set Attack Speed Multiplier
9. Set Tears of Atonement Multiplier


Supported Game Versions:

We strive to keep our trainers up to date with the latest game versions. WeMod automatically detects which version you have installed and activates the mods accordingly. So there’s no need to worry about which version of the game you have!

Updates and Changes:

  • 09/21/2019
    Started development

  • 09/21/2019
    Released trainer with 9 cheats

  • 08/05/2020
    Bug fixes and game compatibility improvements

  • 08/11/2020
    Bug fixes and game compatibility improvements

  • 10/15/2021
    Bug fixes and game compatibility improvements

  • 12/19/2021
    Bug fixes and game compatibility improvements

Like what you see?

Check out all of the games WeMod supports here.

The Blasphemous cheats have been updated!


  • Released trainer with 9 cheats

Please post in this topic if you run into any issues!

1 Like

Hey! I’ve been using your trainers since before WeMod and such and really want to thank you. I have a question and I hope you don’t mind me asking. I’ve been scanning for pointers and consistently find a couple that have my tears value but they keep getting overwritten. The floats are using the xmm registers (just learned about xmm haha) and I notice the value never really sticks. Do you have any tips for me to figure this one out a bit on my own? Still gonna use your trainer but I’ve been stuck! Thanks!

Hopefully he finds time to answer your question but he may not as he’s always hard at work on trainers :wink: I would try the cheat engine forums and/or the cheat engine subreddit if you need a quick answer :slightly_smiling_face:

I have not tried every cheat, but I found unlimited flasks and fervor did not do anything for me.

I’m also not sure if the fervor multiplier was working.


New version of the game is out and all the cheats stopped working

What are the chances we could get a quick update today or soon ? All cheats disabled with new update.

Since the game was recently updated then the trainer will also need to be updated to be compatible with the game again

You need to request an update via the WeMod desktop app. Each request through this method bumps the trainer higher up the development to-do queue.
This link explains how to request updates: How do I request an update for games? - WeMod Support.

Helpful related links:

The Blasphemous cheats have been updated!


  • Bug fixes and game compatibility improvements

Please post in this topic if you run into any issues!

1 Like

hay there, thanks for all the work, in my case the game quits when i start the trainer

Hi, I tried playing Blasphemous with the trainer enabled yesterday, after the new update came out. I’m having some problems. Every time I turn a cheat on it automatically toggles itself back off. It doesn’t matter how many times I try to toggle the cheats, it just refuses to let me use them. I’m not sure why it’s happening; this hasn’t happened with any other game that I’ve used WeMod cheats with. :confused:

1 Like

Welcome to the community @marcemgt and @CherryL101. :slight_smile:

First of all, please make sure your copy of the game is legitimately purchased from Steam.

  • If it is from GOG, we do not have a trainer for this version yet, but you can request one in the WeMod desktop app.
  • If it is cracked, again we do not have a trainer for this version and never will.

If your game is from Steam, then click the History button in the trainer, which is under the Play button, and make sure the most recent trainer in the list is selected.


  1. Launch the game first via Steam. Wait on the main menu for five minutes.
  2. Alt+tab to WeMod. Press Play.
  3. Alt+tab back to the game.

See if this makes any difference. :slight_smile:

The Blasphemous cheats have been updated!


  • Bug fixes and game compatibility improvements

Please post in this topic if you run into any issues!

Hi there… I followed the directions and still doesn’t work. Any other thoughts? Also, why would waiting on a menu for 5 min make any difference? I did that, but didn’t see the reason… Thanks for any/all info.

Because sometimes it takes a few minutes for the memory addresses that the trainer needs to inject into in your PC’s RAM to become available.
Most standalone trainers on the internet will tell you to launch the game before the trainer, otherwise the trainer won’t work. Most of the time that’s not necessary with WeMod trainers, but sometimes helps in certain cases (ie, the game takes too long to fully load on the user’s PC so WeMod’s injection times out).

Under the Play button in the trainer is another button labelled History. Click this and make sure the most recent trainer is selected, which was released 10 days ago.

Also ensure your copy of the game is legitimately purchased from Steam, as opposed to another store or cracked.

Thanks. Did everything mentioned above including checking history and yep it’s a Steam purchased game. Do you know if anyone has actually confirmed this to be working? The last big update the game made changed the way health is even represented on the UI, so would love to know if this has worked for anyone at all.

You’re right. Last big update changed the way health is presented.
But unlimited health isn’t the only cheat that stopped working. Unlimited fervour, for example. Didn’t try the other cheats.
I also did what was suggested here, to no avail. An update for the trainer is needed.

Edit. Actually I was playing for a while can’t tell how much, but more than 5 min (had started from steam), and gave it another try. While the game was running I hit “Play” from the trainer and at least life and fervour cheats worked, didn’t try the others.

I appreciate the update, but this is not how the modder should or did work in the past. Trying to wait for X amount of time (I’ve waited 5 min, 10 min, 30 min, etc. on both start and in-game), cancelled and alt+tabbed multiple times trying different patterns and nothing. I would like a dev to confirm this is working. I tried the same cheats that you mentioned and nothing.

On the contrary, most stand-alone trainers have always (and still do) require you to launch the game first then alt+tab to activate the trainer. This is from personal experience of using trainers for two decades.

With WeMod that isn’t always necessary - but in some cases it still may be. This is usually either due to:

  • The way the game is made. For example, World War Z on Epic Games will crash if you turn the cheats on before you start the game.
  • When the game loads the required memory addresses in the PC’s RAM that the cheats need to inject into. For example, some games may not load the require memory address until the user has competed an action in the game to trigger it to load (ie - sometimes 1-hit kill cheats require you to kill at least 1 enemy first).
  • The user’s PC. For example, some PCs may take longer to load the required memory addresses for the game in the user’s RAM which the trainer needs to inject into.

Would love in the future if there are notes to make these work versus just waiting as this is not how this mod had worked before. The previous cheats prior to the last update worked immediately which is why I originally reached out. Even in your comments above, you stated that there are known workarounds for other games. Can one of the devs actually try this and give some steps to reproduce to make it work for this game specifically?