Cannot seem to use Infinity anymore

Okay so here’s my issue.

I used Infinity fine before the update ever since then it has been a nightmare to use. I have looked at various other discussions with problems similar to mine and tried all of the suggestions and not seemed to get anywhere. Any help or advice would be truly appreciated as this is starting to really bug me now.

First of all I have Bitdefender and i’m not sure if this may be a big cause of my issues but it seems to be where a lot of wires cross. I have turned it off or think i have and added; infinity, the game i want to play and Steam to its exclusion lists, which there are several of. I’ve uninstalled Infinity entirely from my computer by using Ccleaner and manually going into files and deleting them or to uninstall them.

After all this is done and my automatic antivirus is turned off i reinstall Infinity. when it is installed i run it as an admin, up to this point everything seems to work, my games are there, the trainers are accessible and everything looks like it should. I boot the game through Infinity like you normally would, i wait until the game starts, i try to use teh hotkeys and nothing. So i switch screens and notice Infinity is closed so i reopen it to find either my games are no longer there or there are no longer any trainers to use. the only way to get these back is to do a full uninstall and reboot.

At this point i look into what might have happened, it looks like bitdefender creates a false positive and has quarantined the files due to being malware which cannot be moved back, i have emailed bitdefender to tell them this is not the case but i am waiting a response. i was just wondering if any one might have a more detailed idea of what to do other than the usual ‘uninstall, run as admin and add to exclusion list.’ one I’ve seen several times.

Sorry to ramble on but this is beginning to frustrate me now and I am not tech savvy enough to be able to figure this out on my own, clearly.

Sorry your AV is being such a pain. Bitdefender has been especially annoying for us too. Do you know exactly which files are being quarantined? Have you enabled the miner for Pro or installed Version Guard from Settings?

Thanks for contacting them as well.

The files that are quarantined is basically everything that comes in the install folder along with anything that is connected through this whole process, i forgot to mention after a while it also deletes the game form my PC. the reason for quarantine is Atc4.detection.

I don’t have a pro account but i did just install the version guard and all the trainers did come back but I’ve not tried a game yet.

1 Like


I’ve found a solution that seems to have worked. Delete Bitdefender.

Everything works as it should now and windows defender is taking up what bitdefender should have been doing. Thanks for your time though and hopefully anyone else who has this problem can see the solution i’ve found.

I have the same problem with Bitdefender whenever I try to load the far cry 5 cheats, Bitdefender starts deleting Infinity, all other trainers work that don’t have to modify the files.
But I have the solution to fix the problem.
I emailed Bitdefender (awhile ago) and they gave me the rundown on what to.

In order to resolve this situation, please add the software to the Bitdefender exclusions lists. To do that, please follow the steps below:

A). Exclude the files from being scanned by the Bitdefender Virus engines

  1. Open the main interface of Bitdefender 2018 then click on the menu button from the upper left corner.
  2. Select Protection from the left sidebar, then click on View Features from the right side of the window.
  3. Click on the gear icon under Antivirus, then select the Exclusions tab
  4. Click on the Add button next to List of files and folders excluded from scanning
  5. Click browse, locate the files you wish to exclude, then click on OK
  6. Choose whether to exclude the files from on-access scanning, on-demand scanning or both, then click on Add.

B). Exclude the process from being monitored by the Advanced Threat Defense module, which relies on identifying malware based on the behavior of the applications:

  1. Open the main interface of Bitdefender 2018 then click on the menu button from the upper left corner.
  2. Select Protection from the left sidebar, then click on View Features from the right side of the window.
  3. Click on the gear icon under Advanced Threat Defense.
  4. Click on “Add applications to the whitelist”
  5. Select the process for the application you wish to exclude (a .exe file normally) then click on OK.
    After you follow these steps, please restart the computer and check if the issue persists.

but it still was not enough until I did this.
While whitelisting (Part B) infinity ( Located C:\Users%UserName%\AppData\Local\Infinity ) I also whitelisted all the .exe files inside the infinity folder (Infinity/Update/Infinity/Squirrel/WeModAuxiliaryService) and then it was all working again. before this Bitdefender would CONSTANTLY delete infinity after 4.0 update but now its all good again and works as it should.

Hope this helps anyone else with bitdefender.


@frank this needs to be pinned or something for people facing similiar problems!
Thanks Think1n for that one. That will help a lot of people

Just delete bitdefender. Dont need it if you know what your downloading any how.
Windows virus protection is plenty good enuf. Ezy pzy

I have Bitdefender Total security family pack for 2 years… not going to delete it because i cannot figure out how to do something. Instead work with others and figure out another way.

1 Like


To be honest I did all of this and still had no joy, i even white-listed things connected to Infinity such as the games, steam etc. Maybe i didn’t do it correctly or something but I’m glad you’ve found a solution to this issue as well and I do agree that this needs to be pinned so that as many people can see it as possible because clearly we’re not the only ones that has had this issue.

Would you be able to tell me which files are being quarantined, with your quarantined items is there an exclusion for when you return them to their original place? (Protection Features > Quarantine > View Settings > Create Exclusion for files (Ticked). As when you put them back from quarantine it will allow them to be there without Bitdefender scanning them. (Important) Only return them back when you have either restarted your computer or not in a disinfection process (Important)
Once Bitdefender has started a disinfection on infinity, IMMEDIATELY delete infinity and restart the computer as there is no way to save it at this point and it will just keep popping up saying that warning infected files ( I have 100+ from infinity 4.0 xD ).
The best way to install infinity is to have the setup on the desktop then do a fresh boot, the reason for this is when you boot your computer (shh I didn’t tell you) Bitdefender isn’t on for about 10-30 seconds. so install infinity from the desktop quick to get around it not installing properly and having error logs.
If there is anything else you want help with I’ll try my best.

P.s. I have been talking with Bitdefender to see If they can get Infinity whitelisted… Meaning no more of this having to workaround bull****. :smiley:

1 Like

Ok. So I did this for a test.
I did a clean windows 10 latest version on another computer that I have. then I installed Bitdefender put my keys in and all good, Proceeded to download Uplay and Installed it, then downloaded Infinity and installed that too, I then proceeded to do the BitDefender method ^ Step A and B and the extra’s and then restarted my system, I proceeded to download Farcry 5 and Ran the game like normal to (For Installers (Direct x/.net framework/etc…)) Loaded my game and then closed it. I then chose the game from infinity (Had to located Farcry5.exe) then launched the game… Game crashed??? was getting a Tobii error, so relaunched the game from Uplay and crashed again same error, verified the game errors left and right for some reason about Tobii so then I just deleted the game re-downloaded it and started it up again (Hate how the installers have to install again even though we have them) loaded into my save then quit. relaunched infinity and re-located the farcry5.exe and then launched from infinity and it worked. Tested out some of the cheats and they were running fine.
Other than from the Tobii crash there were no other problems, none from Bitdefender and no Crazy Disinfections. Tobiieye tracking pfftttt, ‘who needs that when you have super Jump’.

1 Like

id like for the previous version of infinity to be reinstalled as this one is not usable for me besides I prefer its ease of use rather than this crap I got now its too confusing and doesn’t work well! instead of forcing people to use this u should give them a choice that is why twitch isn’t that big of a deal cause everyone wants xfire back just like they will the older version here

It will be changed again in v5. If you have actual suggestions to improve the UI, let them know. Demanding that they go back to the old theme and never change anyting will not work.


We would appreciate suggestions instead of just calling it crap. We are willing to make changes that make navigation easier.

There is a 0% chance of us going back to V3. It isn’t compatible with version guard and v5 is a complete UI redesign.

Post your suggestions in the thread chris linked. Complaining and calling it crap will not lead anywhere. Spend juat a minute on telling us what you don’t like and what you want changed, what you liked about the old layout etc.

There have been so many updates to v4 already, maybe your suggestion will be easily implementable in next update. If not, v5 is coming soon with full features.

guess then u have lost a customer if u wont change it back and I will notify others and perhaps talk them into going elsewhere!!! wasn’t demanding anything but if u want people to use then u need to leave well enough alone and let people use what they are comfortable with and not force things not wanted on customers as that is a good way to loose them and u lost me and perhaps many others due to inability to use this site anymore!!!

I’m having the same problem of Infinity simply not working with any of my games. I’m just getting a red “no” cross on all cheat options. I use Avast antivirus and it doesn’t see Infinity as a threat, however, even if I turn it off, that does not resolve the issue. Any help would be appreciated!

(I tried to upload a screenshot, but the cursor doesn’t show)

You are delusional, please leave this site.

We asked you to make suggestions about improving the design. As I stated just going back to V3 is not possible. V3 does not support core features of V4 and would require dozens or maybe hundreds of hours of work to make them work. It isn’t worth it when V5 is already in development.

The behavior shield is trigged by this program it seems.