Can't install the setup


So this is the first time that I installed this setup but apparantly I cannot dowload it. It says:

Installation has failed.
There was an error while installing the application. Check the setup log for more information and contact the author.

I closed all my anti-virussen/steam/discord/etc…
I still keep getting this message.

Sorry for disturbing, I know this might be a common thing.


You sure you disabled your AV completely ? Probably need to whitelist the wemod exe’s
Usually that’s what failed to download is caused from

me too… application was running, closed and deinstall… then i tried to install again but it failed with the same error…

A failed installation is the result of an antivirus interfering or a firewall on your network.

Please see this thread: I can’t Install WeMod.

im having the same issue the full log file is below.

14712> 2020-11-22 21:45:07> Unhandled exception: System.BadImageFormatException: Could not load file or assembly ‘PresentationFramework, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35’ or one of its dependencies. The module was expected to contain an assembly manifest.
File name: ‘PresentationFramework, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35’
at Squirrel.Update.Program.executeCommandLine(String args)
at Squirrel.Update.Program.main(String args)

=== Pre-bind state information ===
LOG: DisplayName = PresentationFramework, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35
LOG: Appbase = file:///C:/Users/Admin/AppData/Local/SquirrelTemp/
LOG: Initial PrivatePath = NULL
Calling assembly : Update.exe, Version=, Culture=neutral, PublicKeyToken=null.

LOG: This bind starts in default load context.
LOG: No application configuration file found.
LOG: Using host configuration file:
LOG: Using machine configuration file from C:\Windows\Microsoft.NET\Framework\v4.0.30319\config\machine.config.
LOG: Post-policy reference: PresentationFramework, Version=, Culture=neutral, PublicKeyToken=31bf3856ad364e35

Yours is a different issue. Your .NET Framework is massively outdated at version 4.0.
Update your .NET Framework. The latest version is 4.8.

Try installing .NET 4.8:

@Ravenfyre 4.0.30319 can be any 4.X version.