Cant install wemod 7 new update

i recently opened wemod and i was told to update wemod now or later. i installed and it eleted my wemod app and shortcut i removed everything i had from wemod from my pc and now everytime i try to install it says installation failed check the setup log for more info.? i turned off my antivirus and tried installing but i got the same message. it was working perfect before this happened i really dont know what happened.

Welcome to the community. :slight_smile:

Sorry to hear of this issue you are facing.
This is commonly caused by an antivirus program or firewall interfering with WeMod.
Please follow the steps in this post: I can’t Install WeMod / “There was a error installing the application” - WeMod App / Support.

Keep us updated. :slight_smile:

i tried doing that and it says the same thing “there was an error” “check the setup log for more information” i disabled antivirus before installing and i cant open wemod.exe.

Thanks for the update. :slight_smile:

After you download WeMod, could you try adding the setup file as an exception in your antivirus before you launch it? Even though the antivirus is “turned off”, there are still parts of it running in the background.

Still an issue?

  1. What antivirus do you use?
  2. Are you using your own home internet or an institution’s internet (ie college/university)?

ok i just tried that and got the same error message. i use the windows defender antivirus and im on home internet.

Thank you. :slight_smile:

Another thing to do is to make sure you have the latest version of .NET Framework on your PC or that it hasn’t become corrupted (which just randomly happens on Windows at nobody’s fault).

Here is the official link:

it opened!!! Thank you so much for the help

Glad to hear that it works for you now. Enjoy WeMod and always feel free to pop into the forum if you need help, have questions or just to grab a free game from the Deals section. :slight_smile: