Can't install WeMod - despite following support suggestions

Hey guys.

Like the titel says, I’m having some problems installing WeMod.
and appologies in advance, because this is gonna be a long one, but I just wanna be clear and sure that nothing is left out and hopefully better the cances of someone having a solution.
And sorry for any typos, english isn’t my first language.

So first off, I’ve tried every suggestion I’ve been able to find on the forum and support sites, including stuff like:
Why can’t I install WeMod
Ravenfyre’s solution
None of it works. I’ll admit I’m not the most tech savvy guy around, but I’d like to believe I followed the suggestions to the letter.

I’ve never had any issues before and used to just install and uninstall as a saw fit, usually when I did a clean up of my PC, which I recently did, recently, after installing a new SSD and it suddenly stopped working, I started getting this message:
Install error
along with this setup-log:
SquirrelSetup-WeMod.txt (6.7 KB)
(for some reason my computer has mixed WeMod and Discord in the log, but it’s the exact same log, so just replace the names and it’s the same)

That’s the situation when I try installing WeMod directly from the download.
I followed a suggestion regarding deleting the squirrel-temp folder and then I started getting this log:
Squirrel-Install.log (4.1 KB)

It’s important to note that up until this point, the is absolutely no trace og WeMod left on my PC, despite the log saying something about WeMod running in the background, it’s not, there’s no trace of it in task manager.

Now we get to the bit weirder part. I started asking for help on the discord-support chat and got in contact with a few of the PROs, One of them sent me the WeMod files as a Zip-file and wanted me to unzip the file into the AppData folder, which gave me this:
WinRAR Diagnostic message.txt (18.1 KB)

I then just tried to unzip the files to my desktop in a folder there, which I could do no problem, then I tried to move that folder to the local AppData, getting this error:
Copy-paste error

And it gets better, if I go into my local AppData folder, I can’t see a WeMod folder, but I get that message when I try to copypaste my unziped folder in there.
If I try just making a new WeMod folder I get this:
Folder already exist
Which is weird, because like I said, there is no folder in there, I can’t find or see one named WeMod. If I try clicking yes to replace the old folder with the new, then the new folder just disappears.
I also found out, that when I try to unzip the file into the AppData and I follow the file thread to that place, you know this part:
there actually is a WeMod Folder in the bottom of the local folder, but if I try to click on it, I get the previous “Location is not available” message…

So long story short, I’m at my wits end… the PROs on discord suggested I make a post here, hoping someone had an idea of what the hell is going on, so any advice or help would be greatly appreciated.

As a sidenote though, I currently have acces to WeMod, as I am able to launch and use the program from the unziped files in the folder on my desktop, but since the app i technically not installed on my computer, the PROs and I conclued, that when the next update comes out, I’d pretty much be back to square one, since it most likely won’t be able to properly update and install correctly.
Currently nothing happens if I click the update.exe, but I speculate that’s simply because there is no updates, but I honestly have no clue.

I’m not super tech-savvy either, but it sounds like your hard drive is having some issues. I’d open your file manager, right click on it and choose “Properties” then go to the “tools” tab (on Windows 11) and do some error checking.

Also make sure you’re operating in admin mode and not using a secondary account on the system.


Sorry about any inconvenience this has caused you! When a staff member is available they will respond with help.

Have you tried restarting your PC? It is possible there is still an instance of WeMod open or some process running that is preventing it.

Sorry for delayed respons, had to go out of town for a while.
as for file manager, could you elaborate what you mean? as far as I can tell, I just have the default file explorer and I’m not sure where in that I’m to do what you suggest

The PC has been restarted multiple times, the problem has been going on for a few weeks. so lots of natural restarts over the course of daily use and also multiple restarts during the attemtps to fix the issue