App Horizon

Castle crashers modding not working

I’m trying to mod castle crashers but every time I try to save it says open file but I don’t know what to open. And now it’s saying nothing, clicking save does nothing, it started with an error saying invalidargument value of 255 is not valid for selectedindex but I have no value at 255 and I hit quit on that.
Ok now I have it back to that message and saying open a file first when I try to save

Hi @King_Stein and welcome to the community!

For your reference, here is a thread that explains the functions of Horizon and how to use them: Horizon | The Basics. This should help you out since the program hasn’t changed all that much since the initial release.

Let us know if this helps you out :slight_smile:

I tried looking at the link to the error list but it said page not found. And I suppose I’m not that new with this, jus always had to use a save file and account. Castle crashers only uses the account. But the account I’m trying to use was kinda modded when I first got the game forever ago so idk if that’s what my problem is. I’ve already modded oblivion with this no problem

Thank you for the link btw

1 Like

I’m guessing that Horizon doesn’t have any mods for that game:

It isn’t listed in the top modder banner and I tried modding a save found on the web and see this window:

image

You may need to find another save editor for Castle Crashers to mod your save since Horizon doesn’t seem to support it.

Sorry for the bad news…

It’s under Mod Package, There’s a tab for it. Here are the errors I’ve been getting.HorizonInvalArg ! when I first open the tab HorizonCantSave|385x302 when I try to save

And I’ve tried resetting the stats and inventory back to 1 or 0 but it won’t save. It says it Saved and after i save and rehash it still pulls up again as the stats from before.

I made a copy of my profile on my pc and since it says to open a file, I open from there and it allows me to save. I then save it to my usb and it says it saved but when I check it, no change. Also when I try to edit other characters I get this:

Oof. I honestly didn’t know Castle Crashers was moddable with Horizon :grimacing:. Maybe try running Horizon as admin?

I figured it out, the last person who modded my account put some of the stats too high and I had to go thru and fix all of em. Big oof. So it’s saving right and everything now, but now when I put the usb in my console and start the game, it tells me that my game was last played on a different console and loads the stats from my last game save on my Xbox. But I can’t edit the game saves on my Xbox because it saves to my profile and nothing else.

You will need to change the console and profile IDs to match those of your Xbox and profile. An easy way to do this is to copy your profile to the USB and open it in Horizon. Then you can copy the IDs into the respective fields in your save. This should allow you to open the modded save instead of it reverting to the other save.

Let me know :slight_smile:

1 Like

Noop, they matched but I jus copied em and tried it and it’s still the same :expressionless: idk what it could be

It was reverting me back to level one with no unlocks before and it’s jus reverting back to my last save now tho so that’s progress ig :rofl: