App Horizon

Company of Heroes 2 Cheats and Trainer for Steam

This is the official discussion topic of the Company of Heroes 2 Trainer and Cheats in the WeMod app. Please post any suggestions, bug reports, or praise that you may have for the cheats in here!


Download:

Download the trainer and find it in the WeMod app.



Trainer Options and Cheats:

1. Unlimited Health
2. Unlimited Ammo
3. Unlimited Fuel
4. Unlimited Man Power
5. Unlimited Population
6. Unlimited Command Points
7. Instant Troops
8. Instant Construction
9. Instant Command Cooldown


Screenshot:



Supported Game Versions:

We strive to keep our trainers up to date with the latest game versions. WeMod automatically detects which version you have installed and activates the mods accordingly. So there’s no need to worry about which version of the game you have!



Updates and Changes:

  • 05/05/2017
    Started development

  • 05/08/2017
    Released trainer with 9 cheats

  • 05/10/2017
    Bug fixes and game compatibility improvements

  • 05/10/2017
    Bug fixes and game compatibility improvements

  • 05/10/2017
    Bug fixes and game compatibility improvements

  • 08/31/2018
    Instant Command Cooldown cheat added



Like what you see?

Check out all of the games WeMod supports here.

4 Likes

I am having issues loading up the cheats, it keeps flagging that it is having issues downloading despite having a solid internet connection, and the software is not being blocked by my security software, it seems to be an issue with this one alone.

Please post Infinity v3 problems in the thread where it’s being discussed.
It’s a v3 problem probably not a trainer problem

2 Likes

Mine keeps saying it loading

Every time I start the game with infinity, the game minimizes at random times. idk if it’s a CoH2 problem, or Infinity. How do I fix this?

vou testar pra ver se esta funcionando

There seems to be a problem, in that I cannot activate the cheats when playing any mode.

Could You Please Update This Trainer Thanks

All cheats work for the newest version

Will I get banned for having this?

Its for singleplayer only so no

I think this trainer needs updating for the May 29th Update please. It no longer works with that version. Thank you. :slight_smile:

Everything works perfectly fine

1 Like

Thank you for your reply.

In Infinity it says “No Supported Trainers Available” and when I use the only one listed below that, none of the options do anything. I select them, they beep to say they are on, but nothing happens. My forces still take damage, things aren’t made instantly and my resources aren’t infintie. It worked 2 days ago weirdly, but since then it hasn’t worked. I have changed nothing save for installing some mods from the Workshop, like maps and skins.

Infinity says the same for me.
Using the older version works perfectly fine though no problems at all.

I can’t say the same. It just doesn’t work at all now, even after reinstalling the game with no mods at all. I don’t know what has changed in 2 days but nothing works at all with it.

You still get a checkmark next to play and are able to toggle the cheats?
Try manually toggling them not by hotkey.

Also disable your antivirus if you have one. If you have Bitdefender you need to uninstall it.

Checked it again with a fresh install just in case and it still works.
Where are you trying to use it?

Yep I’ve tried doing it both ways, via clicking and hotkeys. I seem to have mixed luck, sometimes I have to wait until I’m in game, other times doing it when I’m on the main menu makes it work. Is there a general rule of thumb for when to activate the options?

I’ve got it to work in this session I’m in now, that’s 1/5 today lol, better than none! It seems to be a bit tempermental/works when it wants to. I’ve made exceptions for any and all Wemod/Infinity folders on my PC and for my games in general too. Come to think of it, this started the same day I made the exceptions for Infinity, but I can’t see how that would affect just one game/trainer.

I’m using the proper Steam version btw.

I always activate them when I’m already ingame.

With session do you mean against bots?

Yes I always play against bots whenever I use the trainer. And by session I mean having the game running. I’ve tried a further 3 times as testing and only in one of those did the trainer fail to work. It’s strange, I had the exact same conditions set, all vanilla no mods enabled. But at least it is improving.

Fingers crossed it keeps working as it is, I vastly prefer the Infinity trainer to some of the others out there. Much easier to use and understand. Plus the forums actually give help.

Thanks for your time, I’ll post again if it stops working over several games again.

1 Like