Dawn of Man Cheats and Trainer for Steam

I´d really like to break this game with an insanely high population. Unfortunately, the population in the late game won´t go any higher than between 300 and 500. Is there a way to make a cheat for the villagers to resist against dieing of old age? Or maybe a cheat to incrase child birth rate and stuff? I´d really appreciate these options.

Also, the infinite mineables cheat doesn´t really work on copper and tin for me… any help?

Have a nice day! -xxxAlexxxAlexxx

Infinite mineable resources only seem to work if you select the deposit at least once after activating the cheat. It seems building a mine on the deposit cancels the cheat, so you have to place an ore mining order instead of building mines.

From what I can see, any building built with the instant build cheat seem to prevent any task from being done in it. Animals in stables are left to starve, mines produce no ore, items don’t get crafted although they do consume the resources needed to craft them !
Buildings built with the cheat also won’t get repaired / maintained if they get damaged.

Maybe a cheat that would set the building to 99% and then let the people build that last 1% to complete it would solve these issues ?

Temperature cheat prevents your people from freezing to death in winter.

Hi, it still says compatible in the WeMod program, but when I use most of the cheats (health and fast building seem not to affect it) any resources I produce don’t show. Might need some updating

1 Like

Health cheat works fine for me. Are you using the stable version or beta version of the game? Cheats are only meant for the stable version.
As for fast building, it doesn’t make your people build faster, it works when you put down a new building foundations and the new building is then instantly created. However, the buildings created that way seem to be a bit buggy so you may want to avoid that one :neutral_face: That resource bug you have is likely created by the instant build cheat being left on, you should switch it off when you dont need it.

1 Like

Thanks for helping people use the trainer. Hope they read your comments on the ideas.
Thanks again for suggestions! :+1:

thanks, that cleared it up :slight_smile:

“Easy Consruction” cheat only works on buildings NOT on items. I always leave this cheat on/off but still any resource i produce does NOT show up in a warehouse or granary. I’ll try to restart the cheats and the game.

EDIT: I restarted the game and it worked properly at first. However, when I want to build a building, I turn “Easy Construction” cheat ON but after using this cheat any resources I produce don’t show up. I tried ON/OFF to no avail.

Unlimited Health work, but if many enemy shoot one guys, he can die
Unlimited banking resources, don’t work, ressource decrease in stock

it would be interesting to have:
cheat add population ( birth or immigrant)
cheating: always young (not dead old age)

Thank you

As of latest update free trading doesn’t work.

2 Likes

Yes, it does seem that game update 1.7 prevents the “free trade” cheat to work properly (it activates then deactivates immediately). However, for some reason, the “request update” button does not appear in the wemod client.

2 Likes

Hey, i LOVE the trainer.
Just one small suggestion, could you make it so that instead of instant building it makes the buildings free and they still get to build them? you dont get the bonuses otherwise

Can we get an update to fix the Free trade option? That is a big one. Thanks

I have the same issue regarding free trade.

Want to bump an earlier issue of the Easy Construction option breaking the ability to gain resources and the Unlimited Bank Resources not working at all, as items still decrease.

1 Like

Also having the easy construction and free trade issue mentioned above.

2 Likes

Unlimited Bank Resources cheat works fine for me. It is only meant to stop resources from riverbanks decreasing from the river so you can fish forever.

Can confirm that all cheats, except free trade, works fine.

Maybe it’s just me but Easy construction seems to be breaking crafting again. along with the free trade issue these are the only 2 issues i have.

3 Likes

Seeing this same bug today

1 Like