Destroy All Humans! 2 - Reprobed Cheats and Trainer for Steam

Destroy All Humans! 2 - Reprobed
This is the official discussion topic of the Destroy All Humans! 2 - Reprobed Trainer and Cheats in the WeMod app. Please post any suggestions, bug reports, or praise that you may have for the cheats in here!

Download Trainer

Download the trainer or find it in the WeMod app.

Trainer Options and Cheats:

1. Unlimited Character Shield
2. Unlimited Jump
3. Invisibility
4. Unlimited Bodysnatch Time
5. Unlimited Resources
6. Edit DNA
7. Edit Furotech Cells
8. Edit Furotech Reactors
9. Unlimited Energy
10. Ignore Ammo
11. Unlimited Jetpack Fuel
12. Unlimited Cloaking
13. Instant Kill
14. Game Speed
15. Set Character Move Speed

Important Notes:

Click here to view important information about these cheats.

The mods might require a minute or two to take effect after activation.


Supported Game Versions:

We strive to keep our trainers up to date with the latest game versions. WeMod automatically detects which version you have installed and activates the mods accordingly. So there’s no need to worry about which version of the game you have!

Updates and Changes:

  • 09/01/2022
    Started development

  • 09/01/2022
    Released trainer with 15 cheats

Like what you see?

Check out all of the games WeMod supports here.

1 Like

The Destroy All Humans! 2 - Reprobed cheats have been updated!


  • Released trainer with 15 cheats
1 Like

Well, as usual, this ■■■■ not a cheat
I click on ANY cheat, it goes first to on, and then immediately to off
mrantifun, better go back to the good old cheats, not THIS wemod

1 Like

yep cheats not working…sigh
okay, they are working after changing the exe for the game. had to go into install folder and drag and drop a different exe file then they worked.


I think it might not be working with the DX12 version. I tried DX11 and they worked fine, but that version also runs terribly for me so I can’t use it.

Mind sharing what exe file? I have the same issue, they don’t work and make my game lag out to the point I might as well be playing a slideshow. I’m lucky my PC hasn’t totally locked up, been looking forward to this trainer all day, too…

I’ve added the trainer target hours ago please try again and report back here. Be sure to restart WeMod app before using.

If that’s true then I used it well after you did that, just restarted Wemod and tried again with the same result. It spikes my CPU till everything just locks up, at this rate my PC will croak before it works, and before anyone asks no this the only game I’ve ever seen do this with a wemod trainer. I’ll try the standalone above and see if that changes but I kinda doubt it. :< If there are issues I hope they’re solved as soon as the mods can do so, this kinda sucks…

(Edit) Nope, still lags out. I’ll wait for a few patches down the road before trying again, probably just some kinks needing worked out.

Works fine for me. I press “Play” on Wemod, the game loads, trainer loads, cheats stay active and work. Dunno why ppl are having issues.
Make sure you’re using the DX11 version

One thing I did notice though, is that “Unlimited Character Shield” sometimes prevents buildings being destroyed, such as the case in Albion when you need to destroy the Russian Embassy building during a mission.


Should work for DX12 too FYI

1 Like

when i installed game it put the exe on desktop like usual but couldn’t get the trainer to work, so deleted the shortcut in wemod and pointed it to the dh exe file in the install folder and cheats started working. dunno why that did anything but it did.
Also,at times, it will bring my fps down to 13 not sure if the game isn’t optimized right or its the trainer but it happens.
don’t know how you can choose dx 11 or 12, never got a choice anywhere.

Unlimited jetpack fuel doesn’t work.

This really doesn’t work at all and will affect the operation of the game. Even if I open it all, my weapons will disappear. What’s going on??? I’m thinking about whether I should continue to buy monthly cards。
说一下嗷 真是一点用都没有,开了一些选项,我在游戏里的武器不见了,念力也没了,啥都干不了,还直接影响了我游戏的运行 变得奇卡无比 我认为这是我电脑本身的问题 所以我运行了星际公民 非常流畅 所以我想知道作者是啥想法 后续是否会修补?我非常希望风灵月影宗可以出一个这样的修改器(我第一段英文是表达对作者的尊重)

Tried that and it still lags out, not as quick but the cheats also don’t work either, so… yeah :< I’ll give it a while like I said and wait to try it again later when it’s had a few more updates.

All of the mods are working. It might take a couple of minutes after activating to have any effect.

@DavidSnow, that sounds like a game issue as no one else is reporting it, and I haven’t experienced it either.

A cheat I would love in the future is Infinite Health for the Saucer. The first game had it, so it wouldn’t make sense if this one didn’t.

1 Like

Strange that it isn’t for me. It works perfectly for me when I run DX11 but none of the cheats work even when activated on DX12.

So can we get god mode for the ufo?


So something I’ve noticed is that when using the Unlimited Character Shield option you can no longer destroy buildings using the flying saucer, is anyone else having that issue?

Running the game through DX12 prevents the trainer from even locating the game. I keep receiving the error that tells me to check my firewall or virus prevention software, all of which have the WeMod program allowed on all levels.