Download failed :(

I switched to a new pc, I wanted to download WeMod but it says: download failed, and shows a offline installer option, I clicked on the offline installer and it won’t work too. Can anyone help pls :(. I’m using Windows 10, It worked earlier. :frowning:

Hello! :slight_smile:

This is a commonly a classic case of a security software on your machine or network interfering with the download.

Full troubleshooting is here: I can’t Install WeMod / "There was a error installing the application" - #2 by Ravenfyre. Follow all of the instructions in the exact order they appear.

I have done all of the steps and it just did not work, the offline installer does not work too.

If the offline installer doesn’t work, that means there’s something in your machine, as opposed to your network, blocking it.

Have you checked that you have .NET Framework fully updated, as the post says?
What security software do you have on the machine?
Are you able to upload a log?

same issue hare. online installer and link offline installer also no function. help to fix the link.

Welcome to the community.

Follow the instructions linked in this post: Download failed :( - #2 by Ravenfyre.

why the offline download show like this?


The specified key does not exist.




i cannot use the offline istaller

hi there, don’t want to be not gratefull but i, turned off default antivirus also tried everything above and also still have issue

@bruvvvvJINER @mr_goku @neihc

We’ve recently changed Cloud providers for the installation file of WeMod, and thus, some ISPs are having trouble.
Could you try downloading the installer from here? One of the staff members uploaded it on WeTransfer as a temporary fix.
WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free

Edited to update the transfer link.

1 Like