Dragon Age: Origins - Ultimate Edition Cheats and Trainer for Steam

Works great using the Steam Mod for the EA version of the game! Just had to manually add the executable from the bin folder in the games directory on my HDD to play.

i thought it was time to start another run-through of the trilogy but upon activating the mods (not sure which one)…once a stun is performed onto you or a party member…you are locked in place under a “perma-stun” glitch. is there a way around this? or is this due to one of the mods…

upon further gameplay, i am unable to continue playing as activating a mod (not sure which one) causes the game to crash instantly

Same here i don’t even have to Have a Mod on it just Crashes my game as soon as i hit play and launching it through WeMod

1 Like

I keep getting an error saying the cheats will only work for 32-bit for Dragon Age but there is no 32-bit option :broken_heart:

Try starting the game first. and then when it has loaded up, switch to wemod and start the trainer.

I tried this and it crashes. I keep getting the same error, there is no other options for a 32 bit mode thru steam? I hope they add the GOG version soon. I have tried to troubleshoot from the forums with no luck

so many people have posted the same issue and yet the problem hasn’t been fixed. i pray that someone (if not the creator) can actually get around to this cause it’s starting to become a joke when we just want to play through it and have fun with wemod

1 Like

It would be nice if you could do the XBox version as well for mods

Unfortunately not only do most cheats not work, some just crash your game as soon as they are turned on, maybe we’ll get an update but I doubt it

I’m able to turn on the mods without any crashing issues.
image

As there is a launcher before the actual game, make sure you’re launching the game first via Steam. Then once you can move your char around, hit Play on WeMod.

This was tested for the vanilla or default version of the game, with no other third party mods.

Ive tried the same thing, using Vanilla Dragon Age: Origins, Launch from steam, then clicking on play, then I just get “we’re having trouble loading the mods into your game. Try Restarting your game, or pressing Help for more info”

Ive verified my game files, added the exe file straight to Wemod. uninstalled and reinstalled the game, allowing it through firewalls/antivirus. Nothing seems to work, same thing with Dragon Age 2.

Are there any other troubleshooting methods that you would know of?

Provided that you linked the correct exe for both games, which are located in the bin_ship folder, then I would check antivirus permissions next.

With WeMod, two folders need to be whitelisted.
C:\Users\%USERNAME%\AppData\Local\WeMod
and
C:\Users\%USERNAME%\AppData\Roaming\WeMod

Make sure those are whitelisted. Some antiviruses, like McAfee, are more difficult to work with WeMod. I’d also check the detection history of your AV just in case.
I’ve had people in the past who had whitelisted WeMod, but their AV still flagged and quarantined the specific trainer file they needed.

Due to work, my AV is not something I can manage, but I can see that nothing from wemod has been quarantined or blocked. Its called Sentinel One Agent. Wemod also still allows me to play other games, its just specifically DA:O and DA 2

I was having an issue with the game (Steam version) crashing after playing a character for a while. I was expecting a meta data corruption issues or an issue with memory size issue because of saving state for more things later in the game. The game would crash quicker if I had any of the cheats enabled but it would still crash without Wemod on some saves.

The thing that worked for me was replacing the default game executable (DAOrigions.exe) with a LAA (Large Address Aware) Patch of the game. I have not done too much so far but I was able to run around the Grey Warden encampment and interact for about 20 min with cheats enabled and had no issue.

There is a Steam Community post for DAO titled “Making DA: Origins LAA (Steam)” that talks about this patch.