App Horizon

Dragon Age: Origins - Ultimate Edition Cheats and Trainer for Steam


#1

This is the official discussion topic of the Dragon Age: Origins - Ultimate Edition Trainer and Cheats in the WeMod app. Please post any suggestions, bug reports, or praise that you may have for the cheats in here!


Download:

Download the trainer and find it in the WeMod app.



Trainer Options and Cheats:

1. Unlimited Health
2. Unlimited Party Health
3. Unlimited Mana
4. Unlimited Items
5. Instant Cooldown
6. Remove Spells
7. Unlimited Rogue Stealth
8. No Equip Requirements
9. Add 5 Attribute Points
10. Add 5 Skill Points
11. Add 5 Talent Points
12. Add 5K Gold
13. Add Level
14. Add 1K XP


Screenshot:



Supported Game Versions:

We strive to keep our trainers up to date with the latest game versions. WeMod automatically detects which version you have installed and activates the mods accordingly. So there’s no need to worry about which version of the game you have!



Updates and Changes:

  • 05/01/2017
    Started development

  • 05/01/2017
    Released trainer with 0 cheats

  • 05/03/2017
    Unlimited Health cheat added
    Unlimited Party Health cheat added
    Unlimited Mana cheat added
    Unlimited Items cheat added
    Instant Cooldown cheat added
    Remove Spells cheat added
    Unlimited Rogue Stealth cheat added
    No Equip Requirements cheat added
    Add 5 Attribute Points cheat added
    Add 5 Skill Points cheat added
    Add 5 Talent Points cheat added
    Add 5K Gold cheat added
    Add Level cheat added
    Add 1K XP cheat added

  • 05/18/2018
    Bug fixes and game compatibility improvements



Like what you see?

Check out all of the games WeMod supports here.


#2

awesome will check it out later after i wake up later today :sunglasses:


#4

Write that in the beta thread of infinity please


#5

Will remove the message i posted about the problem i had earlier with DA: Origins. Thank you for the clarification! I apologise for the inconvenience.


#6

The infinite rogue stealth makes active effects on my character almost infinite also. I cannot go to ostagar because it crashes my game, i’m not sure if this is a problem with my game or if it’s the trainer


#7

For some reason “Instant Cooldown” doesn’t work…


#8

when infinity is open i open da origens and the value of almost all of the cheats say OFF and it does not seem that ANY cheats are working i have most of the cheats tied to 3 keys and thats / * - and nothing works at all? plz help


#9

I take it you did attach infinity to the game? Saying Infinity is open and the game aswell is kinda confusing.
Try starting the game first and after that attaching infinity to the game.
It’s normal that the cheats say off when they are not toggled


#10

Everything works fine but once I’m in Lothering trainer either wont load or game will crash, I’ve tried with different characters


#11

It doesn’t work… When I start the game up it works only for the first 10 sec then after it doesn’t work.
Please help.


#12

Hey guys

So I need some help. I recently got DA Ultimate Edition and came across Infiniti today, however, i cannot seem to use any of the functions not even move any of the sliders. Any help would be appreciated.


#13

Did you click the "play " button in top right corner ?


#14

I’m also having this issue. any ideas as to why yet?


#15

Not a single cheat is currently working. Installed Infinity after DA:O Ultimate Edition. I start up Infinity, click the play button, no problems in game, except not a single cheat code is working. No gold, No stat increases, no leveling. Zip Zilch Nata. Not sure if I have to be at a certain point in game for them to work, but I’ve only tried it on a new character thus far. Any assistance available for this issue?


#16

I have tested out Dragon Age Origins Ultimate Edition, and what others are stating, the cheats don’t work. The play button does work, but when the game start, the play button goes back to off.


#17

I am having a problem with the trainer, I’m using it with steam and sometimes it can’t find the game whether I start it with infinity or start it from steam and then click play on infinity. Any particular reason for this or is it just a bug?


#18

I can’t seem to get most of the cheats to work except for Unlimited health for your one character. Any ideas on a fix? And I have tried opening the inventory already.


#19

this trainer does not work for me, any of the cheats work on the game, i`m using the origin version


#20

It seemed to work fine last night, but when I try using the trainer this morning, the game crashes immediately upon pushing “Play” in Infinity. If I try starting the game with Infinity, it will crash as soon as the game loads after clicking “Resume” in the main menu.


#21

Hey! i been trying Infinity for Dragon Age: Origins - Ultimate Edition so far so good but some cheats is not working at all only work with here what is working with me

Work

Unlimited Health

Remove Spells

Add Level

Not working

Unlimited Party Health
Add Level
Add 5K Gold
Add 5 Attribute Points
Add 5 Skill Points
Add 5 Talent Points

there are some cheats that I haven’t try yet…
but ermm please get Unlimited Party Health to work that would be nice because my team mate are keep dying all the time xD