Failed to download


I’ve got a completely fresh Windows 10 installation running, tried to download the Wemod app and it comes back with failed to download. Attempted to download the prepackaged installer, it comes back with an error saying the side-by-side configuration is incorrect and closes.

I’ve tried disabling firewall and antivirus and running a reinstallation. Still does not work. Any help would be useful.

Hello and welcome to the WeMod community. :slight_smile:

Try out these steps. They have resolved the issue in the past for others (including me) who had the same error message as you.

  1. Close WeMod completely via Task Manager (double check under the background processes header too).

  2. Uninstall WeMod via the Add Or Remove Programs tool that comes with all Windows PCs.

  3. Navigate to these directories and make sure they have been deleted, if not manually delete them:

  • C:\Users\YOUR_NAME\AppData\Local\WeMod
  • C:\Users\YOUR_NAME\AppData\Roaming\WeMod
  1. Restart your computer. Once restarted, disable your antivirus.

  2. Download and re-install WeMod through this direct link:

  3. Add WeMod as an exception in your antivirus before you launch it.

If you have either of the following, there are some additional steps:

If you are using an internet service provided by a school/college/university, you’ll need to use a VPN to download WeMod as there is an additional layer of security that you cannot control. Try Opera browser’s free built-in VPN.

Hopefully this resolves your issue. Let us know if it does or not. :slight_smile:

Thanks for your response. Here are the result of the troubleshooting:

  1. Definately closed. Restarted to be sure.
  2. WeMod doesn’t exist in Add/Remove Programs (as it’s a fresh Windows 10 Installation)
  3. WeMod folders do not exist in any of those folders.
  4. AntiVirus & Firewall have been disabled with Windows. I know this because it constantly reminds me that my computer is at risk. I have also restarted. Again.
  5. Downloaded the linked installation file. Came back with this error: image

Are there some pre-requisite software that I’m missing? I saw something about .net but thats all already installed. It worked on my previous installation of Windows so I genuinely don’t know why it’s not working now.

Weirdness. :thinking:

Here’s a quote from a previous thread where someone who recently updated Windows had an issue with a specific game, try this too:

From this thread: Borderlands 3 issue after PC upgrade to Windows 10 - #2 by Ravenfyre. Never got a reply to let us know if the troubleshooting in that thread helped or not.

Having the same problem, was working fine a week ago. Uninstalled app as no longer needed, yesterday I realised I needed it again (my fault). And now doesn’t work, fails to download. Tried on a different laptop and connection, still same.

1 Like

Same problem.
WeMod.exe refuses to run. WeMod refuses to download from the official website. I get the “Failed to Download :(” quote in the splash screen.
When trying to use the Package installer provided on WeMod’s support page I get the same “Side By Side Configuration” message as shown in this thread. It only happened yesterday. I’ve spent all night / All day today trying to find a working fix. Tried fresh installs, Visual C++ reinstallation, .NET Framework, System Restores. I checked the Error in Event Finder it says there is an issue with “manifest on line 0. Invalid Xml syntax.”
Unfortunately still no luck :frowning:

1 Like

Sounds like something that might need to be looked into a bit deeper by the WeMod team.

@frank, could you take a peek at this when you have a spare moment, please? Thank you. :slight_smile:
(He’s WeMod’s awesome dev, he’ll pop on to look when he’s able).

1 Like

Great news!
I was actually just telling a few work colleagues about WeMod, trying to convert them!
Cant have it not work now can we :stuck_out_tongue:

I have been having this problem for DAYS. I have no luck getting this to install on my computer even after following all instructions, I am a little bit lost on how to get it installed at all now.
Even the offline link doesn’t work, any ideas?

Try this one.
If its not downloading gotta be something blocking it its only an app but AV dont like it

It doesn’t seem to be something blocking the package installer, that just seems to have some sort of issue.
The official WeMod installer may be being blocked, however I have tried disabling every aspect of AV / Firewall on my system to get it to work.

1 Like

@RenegadeB91, @AdelphaFreya. Try using a VPN like Windscribe to install WeMod. Here’s the link for the installer:

This is a problem with WeMod itself, the app isn’t installing properly on the latest version. Installed last week and everything was working fine, tried a fresh install today and nothing is working whatsoever.

Not necessarily. The side-by-side error is most commonly caused by Microsoft, from my understanding. Either due to a Windows update corrupting a system file or corrupting any installed Visual C++ Redistributable packages. Maybe you’ve recently updated Windows like the OP? It wouldn’t be the first time a Microsoft update screwed up people’s computers.

To everyone having this issue. Just in case the problem is caused by Microsoft’s recent update, could you please try these troubleshooting steps and report back if they resolve the issue or not:

  1. Please are sure your Microsoft Visual C++ packages are up to date and aren’t corrupted. Link to the official Microsoft site where you can do this: Latest supported Visual C++ Redistributable downloads | Microsoft Learn

  2. Try running the installer as admin (right click > Properties > compatibility > run as admin). If you already are, try running without admin.

  3. Follow these steps:

    • Open the Start menu, type CMD. Right-click “command prompt” then select run as administrator.
    • Type sfc /scannow then press enter. Wait for the scan to complete. It may take a few minutes. Once done, try installing WeMod again to see if the issue is resolved.
    • If the issue is not resolved, go back to command prompt. Type DISM.exe /Online /Cleanup-image /Restorehealth then press enter. Wait for this process to complete, it may take a few minutes. Once done, try WeMod again.

In the meantime, the devs, I’m told, will be looking into this as well. :slight_smile:

No,still “Failed to download”.
I think I have only two choices:
wait for the devs,
or format my HDD. :joy: :joy:

I’ll guess we will have to wait for the devs to fix it

Hey everyone,

Does the side-by-side error message pop up right away, or does it take some time after running the installer?


nah right away

1 Like

Still looking into this. Can you confirm that an older version installs correctly?