App Horizon

Far Cry 3 Cheats and Trainer for Steam

#1

This is the official discussion topic of the Far Cry 3 Trainer and Cheats in the WeMod app. Please post any suggestions, bug reports, or praise that you may have for the cheats in here!


Download:

Download the trainer and find it in the WeMod app.



Trainer Options and Cheats:

1. Unlimited Health
2. Unlimited Ammo
3. No Reload
4. Perfect Accuracy
5. Unlimited Syringes
6. Infinite Money
7. Add XP
8. Infinite Skillpoints


Screenshot:



Supported Game Versions:

We strive to keep our trainers up to date with the latest game versions. WeMod automatically detects which version you have installed and activates the mods accordingly. So there’s no need to worry about which version of the game you have!



Updates and Changes:

  • 10/21/2016
    Started development

  • 03/16/2017
    Released trainer with 8 cheats

  • 12/24/2018
    Bug fixes and game compatibility improvements



Like what you see?

Check out all of the games WeMod supports here.

3 Likes

All Trainers [So Far]
Body armor no longer able to purchase after using Infinity infinite health in Far Cry 3 (PC)
#2

I’m trying to use this but every time I try to load it, it says it took too long for the game to load, when the game is already open. So it won’t let me use the tool.

0 Likes

#3

Try running Infinity as an administrator. Sometimes Steam runs games this way, preventing Infinity from accessing the process.

0 Likes

#4

Still doesn’t work.

I ran Infinity as an Administrator with FC3 closed. Hit “Start Game” and it loaded into the game menu no problem. But it takes a while for it to pop up with the error message “The game could not be started or it is taking too long to load.”. Meanwhile the game is sitting in the main menu.

I understand that Infinity is still in Beta and the FC3 menu was just released so there are going to be issues.

1 Like

#5

I’m downloading the game now to check it out. I’ll get back to you in a bit!

0 Likes

#6

farcry 3 on steam seems to have mandatory punkbuster install…not sure why since its a single player game, but when I tried to install it I saw that pop up. Also checked forums and they indicate that a manual install of punkbuster may solve the problem. At any rate, I’m unable to load the game as well even starting it without infinity running.

1 Like

#7

One major problem that I have seen a lot of people have is that if someone tries to load the game from Steam, it doesn’t work. So uninstall both UPlay and FC3, and re-install. That… sort of worked for me. As a backup, I have been running the FarCry3.exe (without Infinity)

But running Infinity as Admin, then pressing “Start Game” on FC3 has been working to launch the game, just not enable the mods.

0 Likes

#8

Its funny that Steam is having this trouble, I’ve got FC2, FC3 blood dragon, FC4 and FC primal and they all load fine. FC3 though doesn’t want to load as I’ve said.

0 Likes

#9

Uplay takes forever to load, that might causing a time-out in infinity. Attach to the game after its done loading instead of launching the game through infinity.

0 Likes

#10

Okay, give it a try now :slight_smile:

Far Cry 3 has two EXEs: one for DirectX 9 and one for DirectX 11. We were targeting DX9, but I changed it because 11 seems to be the default. @stn did yours default to 9?

1 Like

#11

Mine works now.

1 Like

#12

I “accidentally” made this trainer for dx9 version, trainer looks for farcry3.exe instead of farcry3_d3d11.exe which i guess you guys are running.

I’ll make a new trainer for 11 or you guys can switch to dx9 (video settings in game) and this trainer will work.

0 Likes

#13

The trainer works great for me but the game is really laggy. When I use the trainer it lags but when I don’t it doesn’t lag one bit, any idea for a fix?

0 Likes

#14

Good advice, thank you. I ran the dx11 exe as administrator and it now works for me. Not sure why my dx9 is not working given that the trainer was written for that version.

0 Likes

#15

Been trying the suggestions on this page but it’s still not working for me. I’ve tried admin on and off for dx9.exe, dx11.exe, and the infinity app. I’ve reinstalled FC3 and started it with steam and Uplay, and I’ve tried starting infinity when in-game and starting the game from it. All I ever get is: “The game could not be started or it is taking too long to load.” Am I missing something?

0 Likes

#16

Should be farcry3_d3d11.exe (trainer only supports dx11 version).

You have to make sure you are running dx11 version by checking the exe running in task manager, i remember this game switching to different dx version when it liked ( go figure, stupid ubisoft).

if you’re still getting that error despite the proper exe names, its either infinity not running as admin or your antivirus interference. There shouldn’t be any other issues.

0 Likes

#17

Infinity not working with Farcry 3 Blood Dragon, please help.

0 Likes

#18

Far cry Blood dragon is a completely different game and we don’t have a trainer for it yet.

If you want a trainer, request it in suggestions forum.

0 Likes

#19

Help Please?

Infinite health seems to mess up my game in that I can’t unlock full perk tree. Particularly, can’t purchase body armor anymore.

0 Likes

#20

[spoiler]Try the followin: In Origin, go to “My Games” and right click on the title, and press repair install.

edit: I read and i though you meant Mass Effect 3, i mixed phone screen with pc screen :stuck_out_tongue:[/spoiler]

Try this check cache in steam (or Verify in Ubi), this GIF shows how :

If you have it in Uplay:

0 Likes