Infinity Error code:3

I get this error everytime… i already deactivate my antivirus and run infinity with admin privileges… and this error keep showing… please help me…

Sometimes, just disabling the antivirus won’t help, so try adding an exception for the INFINITY app, or try to completely remove/uninstall any AV software, just to troubleshoot your current issue.

Which OS do you have ? Check Windows DEFENDER settings as well. Turn OFF the real-time protection. Uninstall AVAST AV as well.

Try to run INFINITY as an ADMIN/Administrator.

I have windows 10 64bit. And my windows defender is totally off. And im using avast btw. I will try add infinity to exceptions list in my av. Thanks pdhar. Appreciate it!

No worries. Yes, AVAST AV has been picking up Infinity lately, so this could be one of the possible reasons. Add this tool as an exception, or totally uninstall avast, for the time being.

Check the Quarantine (Virus Chest) section as well.

The error 3 is lack of permissions error. Run infinity as admin and add infinity folder to your avast exceptions list.

Hello. I have the same problem, and I’m out of solutions. Nothing works, the error 3 occur on every game I try. I have McAfee Total Protection, and I start to doubt that’s the problem. McAfee doesn’t notify Infinity as a threat and it’s already in every lists of programm allowed to do wathever they want. Should I uninstall mcafee and try if it works?

Edit: tried after uninstalling my antivirus, I still get the error 3. No firewall, nothing, and still the app tell me my non-existant antivirus is posing problem.

Its just a generic message but the error 3 is when infinity can’t inject because of low permissions.Which game is it?


Tried with Dark Souls 3, Darkest Dungeon and Civ V. It seems strange to have a permission problem, I took a look in the system parameters, turned off anything that could bother Infinity, and ran it as administrator, nothing resolved the problem.

Edit: 5h later, still trying. I turned off Windows defender (didn’t even knew I had that), I tried launching the mod before/after starting the game, reinstalling Infinity from scratch, nothing seems to have any effect on the situation.

I also am having problems with this to I have only tried fallout shelter and I have Kaspersky but disabled it and I ran as administrator and it still give me error code 3

1 Like

For me… All of my games…

I wanted to join in for another voice for the problem, all antivirus/firewall disabled + infinity running as admin with nothing impeding it, and always error code 3

1 Like

Hi, same issue here, tried everything (firewall off, admin on/off), the game can be launched from infinity, but i can’t use any cheat. Anyone got an answer ?


@User2586897 We are working on it 24/7 even if it doesn’t seem like it. The issue with this error code 3 is we haven’t been able to replicate it.

Is there a way we could send you some data, or anything useful?

Not me but if @frank needs something.

The latest updated fixes error 3.

I still have the same error after the update, tried admin on/off and firewall off

Just installed Infinity and all I get is Error Code 3 when I try to start any game in my library. Uninstalled it and redownloaded and installed - no change same error on every game. I tried different types of games and games with different loading patterns and no change.

I use Windows 10 64bit and my A/v is Nod32. I have tried with nod disabled and I have an exclusion set for the entire local/apps folder. Nothing I have tried has allowed the cheats to be loaded. I can provide a list of the games tried, but it doesn’t seem to be game specific.

Hope that helps

Are any of your games running as admin?

+1 for Error Code 3 here. Disabled Windows Defender, added Infinity as an exception, running it as an Admin. Won’t work with Deus Ex HR. Always results in Error Code 3.