App Horizon

Just Cause 3 Cheats and Trainer for Steam


#103

grindy and annoying challenges, and nothing that can help to get 5 stars


#104

Whenever I try to download the trainer, it says that there was an error with the download. And without downloading the trainer when I try to enable things in infinity the cheats just flash on and then off again. It happens on every single option. Someone please help 'cause I don’t know what it is.


#105

Well you really dont download the trainer it is in infinity
Are you clicking the " play " button in top right corner after you chose the game ?


#106

Yeah I am :confused:


#107

Huh, I just re-installed infinity and now they all work. Still dunno what it was though.


#108

I feel like nothing is working correctly, infinite tethers doesn’t seem to do anything and neither does Unlock All Gear Mods. And for some reason even when I have the invisible cheat off it is acting like its on (i.e. no one can see me and every 5 god damn seconds the guy on the intercom says something like “lost contact with the rebel, back to normal patrol routes”. Also something with the infinite ammo/no reload cheats completely fucks the RPG causing it to not be reloaded making it a one pump chump.


#109

Most of the cheats won’t work.


#110

yea I like it but why did you have to make it so people who don’t have pro have to use keybindings


#112

Almost everything is working fine, the only thing is that it seems that when using a rocket launcher and you take damage then you will start twitching and the rocket launcher cannot be reloaded. Is this an issue with the trainer or the game?

Overall its a great trainer @unknown_v2


#113

is it possible to add the following cheats?

unlimited jetpack fuel
no weapon overheat
signal lights
unlimited vehicle health

?


#114

maybe possible within a week after release if you can find hundreds upvotes. but not after 3 years after lol


#115

Freeze challenge timer does not work, possibility for repair?


#116

seems like freeze challenge is broken in all trainers. i can recommend to use add time cheat instead


#117

I’ve just gotten Just Cause 3 and the version is Jul 14 2016 (as per my WeMod app). Everything looks good to play but when I begin (on top of that plane with a rocket gun or whatever it’s called) the gun doesn’t shoot and I keep failing over and over again. I turn the cheats on once the game is loaded and it loads just fine both by toggling through the WeMod app and also using the toggle keys themselves. It just simply doesn’t work. I’m new at this sorry, so if I’m doing something wrong, please let me know. I’ve “enabled” the mod downtime thing too. Gosh I really hope this makes sense to someone as I’m a bit lost and my Hubby said this is a great game for blowing stuff up and I was oh so looking forward to it…but in godmode ofc :slight_smile:


Just cuasee 3 not working
#118

the “infinite ammo” dosn’t work on the rocket launcher


#119

Just Cause 4 is out maybe we’ll get a trainer


#120

@YELAG It works for me and if you can’t shoot then just spam click your left mouse button


#121

it doesnt work for rpgs in all jc3 trainers