App Horizon

Kingdoms of Amalur: Re-Reckoning Cheats and Trainer for Steam

This is the official discussion topic of the Kingdoms of Amalur: Re-Reckoning Trainer and Cheats in the WeMod app. Please post any suggestions, bug reports, or praise that you may have for the cheats in here!


Download:

Download the trainer and find it in the WeMod app.



Trainer Options and Cheats:

1. Unlimited Health
2. Unlimited Arrows
3. Unlimited Mana
4. Instant Skill Cooldown
5. Unlimited Consumables
6. Unlimited Buff Duration
7. Unlimited Durability
8. Instant Fate Refill
9. Fast Kill
10. UnDetected
11. Add 5000 Money
12. Add 500 Exp
13. Add 2 Skill Points
14. Subtract 1 Skill Point


Screenshot:



Trainer Video:



Supported Game Versions:

We strive to keep our trainers up to date with the latest game versions. WeMod automatically detects which version you have installed and activates the mods accordingly. So there’s no need to worry about which version of the game you have!



Updates and Changes:

  • 09/11/2020
    Started development

  • 09/11/2020
    Released trainer with 13 cheats

  • 09/11/2020
    Subtract 1 Skill Point cheat added



Like what you see?

Check out all of the games WeMod supports here.

1 Like

The Kingdoms of Amalur: Re-Reckoning cheats have been updated!

Changes:

  • Released trainer with 13 cheats



Please post in this topic if you run into any issues!

1 Like

i am trying to use this trainer and it brings up error that my game isnt the correct
version and try later in game and then i go back to try again once loaded into game and now says to make sure wemod is whitelisted on antivirus which it is…

1 Like

There needs to be a note about changing skill points, If you put in too many you cannot select confirm and level up. which means you have to back out and load last save if you accidently give yourself too many skill points.

2 Likes

Can you please post a picture of the error you’re receiving? Thank you :slight_smile:

I seemed to have figured it out had to uninstall and reinstall and seems to be fine now thanks for responding

The Kingdoms of Amalur: Re-Reckoning cheats have been updated!

Changes:

  • Released trainer with 13 cheats
  • added Subtract 1 Skill Point cheat



Please post in this topic if you run into any issues!

1 Like

This trainer is fantastic. thank you so much. would it be possible to add a cheat for Inventory limit ? i know you need to buy bags to increase by 10, but as far as i know theres only like 6 you can buy.

Also for people using the skills and XP. If you give yourself too many skills you wont be able to finish the level up. And the level cap is 40. i recommend giving yourself XP and killing mobs to level up to 39 without giving yourself skill points. then once your able to level up at 40. give yourself just enough Skill points to aquire all the remaining skills you dont have. and also save before you level up, in case you give yourself too many.

Edit: also just noticed the trainer was updated with a remove skill points option so nevermind that last part lol … but the default option for it on the trainer is F1, which is the same as health.

1 Like

Sir. can you add more functions like multiple exp and money drop from monster like x2 x3 x4 x5
and increase speed for weapon attack animations on multiple choice like 1.5 2.0 2.5 etc.
Thanks you for all of this sir :heart:

great work as always MrAntiFun.
If possible a increase inventory size would be a great addition

1 Like

So I am currently having problems running the trainer at all. Normally I can just pick a game from the app and go, but the trainer told me I needed to download the cheats themselves. So I downloaded them from the post here, and I am getting the same error. It tells me that I do not have the trainer downloaded onto my PC and that I need to whitelist WeMod through my antivirus, although it already is.

Anything I can do to circumvent this issue?

i had this issue at first i had to disable my anti-virus and reinstall wemod once i did that worked no problem

Hey @shaun12500 / @LethargicOptimist.

This should normally help with that issue: Wemod failed loading the cheats into your game

If not, what antivirus program are you using?

Any info on when we can get this trainer for Origin since EA sucks and their Origin/Steam partnership for EA Play Pro users is a joke?

Well im using avast but also had it happen a few times when i had mcafee

Trainer works great!! Game is fun for sure.
However I have a unique problem, with Wemod activated I get a constant clicking like a woodpecker that never goes away. If I disable wemod the clicking goes away.
What is causing that: Any ideas.

Cheers
Kit

2 Likes

Wow I never of heard of that before or ran across the noise. Not sure from me what it could be

I will start a new game. It very well could be a bug in the game conflicting with something. It started about halfway through that first entry dungeon you go through and it could have corrupted an auto save somehow.
Curious if all the junk you could not get rid of in the Dead Kel DLC can now be sold, dropped, destroyed or something. I have many hours with the original game.
Cheers
Kit

1 Like

think i used the add xp too much as i cant level up anymore it just doesn’t move

OK, I have it figured out. If you give yourself enough XP points so you level up with each enemy you kill the game is conflicting with the trainer as the game will not allow you to level up as fast as the trainer allows.
If you level up with each enemy killed about halfway through the first dungeon or the tutorial dungeon if you will, you will be level 23 or so, this is when the clicking starts. So I loaded a previous save(made a lot of them just to see) and do not enter any skill points until you meet Agarth or whatever he is called you will be level 40 provided you made the detour into the side cave and dungeon .
So the game is saying, you are too high a level for this part of the game, it is conflicting with the cheats and starts making this noise.
In the original game I have always used that Wemod cheat and went straight from the gift chest in the first town to Rathir and bought good weapons, gear , armor etc.
So the game scaling is in conflict with the trainer somehow. I started the new game, made lots of saves and played around with it and the conflict noise starts when the trainer allows you to exceed the scaling of the game. It will most likely stop once the game area and scale matches a level 40 character. However that will be end game. There is an unbalance between the trainer and the game scaling and the game says…Whoa son…you cannot do this.
Cheers
Kit