Mad Max Cheats and Trainer for Steam

Mad Max
This is the official discussion topic of the Mad Max Trainer and Cheats in the WeMod app. Please post any suggestions, bug reports, or praise that you may have for the cheats in here!

Download Trainer

Download the trainer or find it in the WeMod app.

Trainer Options and Cheats:

1. Unlimited Health
2. Unlimited Ammo
3. No Reload
4. Unlimited Fury
5. One-Hit Kills
6. Unlimited Nitrous
7. Jump Height
8. Frozen Enemies
9. Unlimited Fuel
10. Unlimited Scraps
11. Unlimited Water


Supported Game Versions:

We strive to keep our trainers up to date with the latest game versions. WeMod automatically detects which version you have installed and activates the mods accordingly. So there’s no need to worry about which version of the game you have!

Updates and Changes:

  • 06/01/2017
    Started development

  • 06/01/2017
    Released trainer with 11 cheats

Like what you see?

Check out all of the games WeMod supports here.

The Mad Max trainer has been updated!


  • New features added
  • Fix memory leak bug
  • Fix random crashes

Please post in this topic if you run into any issues!

@STN would it be possible to give the car unlimited health?


Also Unlimited scrap isnt working, I care because it is part of may humble monthly but you get it early when you pay so yea i think it needs to be updated

1 Like


  1. Inf Vehicle Health
  2. Max Upgrade Points (Griffa Tokens)


Well, it’d be nice to have the car with infinite health, but I like realism. Maybe fart around with Chumbucket’s repair speed a bit for those guys who like driving tanks, without the long waiting time?

Well my mad max trainer was working perfect using the beta v3 but after the update couple days ago nothing works at all . I have tried starting through infinity and also starting the game first then the trainer but nothing , it will make the noise like it’s working but it don’t do anything . Other trainers work tho, thanks

Game update or infinity update?

Sorry it was infinity update v 3.0.1, like I said it makes the button press sounds when I push F1 , F2,

Try uninstalling the beta and reinstalling. We’re trying to figure out what caused the issue, but reinstalling has fixed it for a few people.

1 Like

Let me know if it works! :slight_smile:

1 Like

Ok whats the best way to Uninstall infinity ?

Uninstalling it and using this: - ICDV2.bat - to make sure the cache is deleted

1 Like

Awsome guys thank you ! the uninstaller worked great ! every thing works again thanks

1 Like

That tool only works for Infinity 2

Ah right didn’t know that. Well then he has to delete the cache manually

That tool will clear the Infinity v3 cache, but that doesn’t do anything. Cache is no longer an issue.

Ah right thank you for clarifying I will keep that in mind

Just to add to what Frank said. Deleting the cache still resets Infinity somewhat (the login token for example) but (if frank is to be trusted) it won’t fix any issues. Going to make a v3 version of the tool, wouldn’t be very useful but maybe it could be used when reinstalling/uninstalling infinity to delete left-over files.

1 Like

Reading what you guys are saying but I was using the beta 3.0 then I did the update to 3.0.1 then the trainer for mad max didn’t work , I used the uninstaller , clicked the folder used the auto one , let it do its magic then up popped the new beta all I had to do was sign in and mad max worked perfect again !