Man u realy screwed a good thing up, nothing works now!

Nothing works now. I cant get a game to work with the cheats.


We’re very sorry for the inconvenience. We’re working non stop to fix the bugs right now!


Thank you

your title of post comes off kinda rude


Bit rude of you bro nothing new that comes out is bound to work 100%


no nothing works i was forced to beta now it wont detect games

@User2578903 What do you mean forced to beta? which games it doesn’t detect?

I believe he means that with Infinity 2.0 trying to get the program to connect to the particular game defaults to it sending one of two different messages, one saying that Infinity failed to initialize cheats, prompting you to turn off antivirus software, and the other prompting you to try running Infinity in Administrator. I have tried both for multiple games, and none seem to work.

Oh ok. Yeah infinity has some trouble launching some games.

The solution is simple - run the game then run infinity and attach to game (click start game). Its not that big of an issue. Just needs some thinking. ?That button is misleading @frank can we please change it from Start Game to something like Start so people know it can work even after the game has run, i feel like everyone thinks you MUST run game from infinity or it won’t work which isn’t the case.

The assembler bugs, however i wouldn’t blame him.


Update … when i tried to use infinity it didn’t even find the game just update and it will work just fine

I apologize for the rudeness. It is frustrating when you get excited about a new product and it falls short of your expectations. I will be patient and im sure it will be corrected soon.

I agree on this. Instead of the START GAME button/option, change it to ‘SWITCH to Game’ instead, if a user has already launched the game, or otherwise.


1 Like

Completely understand your frustration. We’re just as frustrated, the last thing we want is to prevent you from using Infinity!

Thank you Zach. I have been using Cheat Engine myself for a long time and it takes time and patience, I no. You have a great idea here and I have been waiting for a product like this. You wont loose me as a customer.

Is your system on auto update or is there a way I can update it myself?

Infinity is auto updated but if you think for some reason it isn’t updating you can simply reinstall it to get the latest version.

Thanks Chris

@STN I did try that prior and it didn’t seem to work however I restarted and it didn’t work for some time but after I tried a couple of games since the restart it started working. I did recently install it so that could have been an issue.

this solution doesn’t work either, i have tried with multiple games, both with all of my antiviruses on and off, and have reinstalled about 5 times now, lised games i attempted this on are as follows;
Hitman: Absolution
Dark Souls 3
Alien Isolation
Bioshock Remastered
Borderlands 2
and finally Metro Last Light: REDUX

i have more games to still try out but if all of these have failed i doubt any other will

Not to kick the dead horse here. But I’m having the same issues with the program as well.

I’ve attempted to turn of my anti-virus, that did nothing.
Always run as administrator, so that one is out as well. And I also attempted to launch the game and then initiate the cheats as well. I’m given the same message.

“Infinity failed to initialize the cheats. Try temporarily disabling your anti-virus and anti-spyware programs because they sometimes flag cheats as malicious software.”

This happens with several different games for me:
Rise of the Tomb Raider
Battlefleet Gothic: Armada
The Witcher 3
And several other games.

1 Like