Metro 2033 Redux Cheats and Trainer for Epic Games

Metro 2033 Redux
This is the official discussion topic of the Metro 2033 Redux Trainer and Cheats in the WeMod app. Please post any suggestions, bug reports, or praise that you may have for the cheats in here!

Download:

Download Trainer

Download the trainer or find it in the WeMod app.



Trainer Options and Cheats:

1. Unlimited Health
2. Free Shopping
3. Unlimited Filters Duration
4. Unlimited Gas Mask
5. Unlimited Ammo
6. No Reload
7. Better Accuracy
8. No Recoil
9. Super Firerate
10. No Spread


Screenshot:



Supported Game Versions:

We strive to keep our trainers up to date with the latest game versions. WeMod automatically detects which version you have installed and activates the mods accordingly. So there’s no need to worry about which version of the game you have!



Updates and Changes:

  • 10/14/2019
    Started development

  • 10/14/2019
    Released trainer with 10 cheats



Like what you see?

Check out all of the games WeMod supports here.

The Metro 2033 Redux cheats have been updated!

Changes:

  • Released trainer with 10 cheats



Please post in this topic if you run into any issues!

enabling no recoil is crashing the game for me

Does it happen for a certain weapon or any weapon you try ? ,Is it instant crash or when you shoot your gun the game crashes ?.

instant crash when I fire a weapon

What kind of weapon are you using ? , I tried it on pistol + pistol like smg i think? and shotgun with no issue.

Edit:- tested on 2 more weapons with no issue .

1 Like

I was having the issue with all weapon, As soon as I press trigger with it enabled the game would crash. If I remembered how to use the we mod log data would send.

Make sure you’re past the tutorial level before enabling cheats, I do remember this being an issue before

1 Like

already a good portion into the game if I restart and try that could it fix?

This.

There’s a quest to collect things like ammo and filters from a desk at the beginning of the game. If you activate cheats before this point you will break your game as you cannot collect these items to trigger the next objective.

Leave cheats turned off until you have passed the collection desk where you pick up your ammo and so on.

the only problem I have is the no recoil working it’s not a huge problem but I want to try to get it to work

I’ll download this game and test it later and see if I can replicate it. Are you past the intro mission?

when i start the game, it doesn’t allow me to continue, just new game.
is this a feature or a bug?

@GamingDomo welcome to WeMod! :slight_smile:

Forgive me for jumping to this conclusion, but saving issues are a common occurrence in games that have been illegally acquired. WeMod doesn’t support such activity (nor do I, being someone who works in the gaming industry).

If that’s not the case, I’ll be happy to help you. Try these steps in order. If one doesn’t help, move onto the next step.

Step one

  1. Open the Epic Games launcher
  2. Go to your Library
  3. Find Metro 2033 Redux and place the mouse cursor over it
  4. Three dots will appear on the side. Click them
  5. Click “Verify”
    This makes sure that the game downloaded correctly and checks for errors.

Step Two

  1. Find the game executable on your computer (C:\ > Program Files > Epic Games)
  2. Right-click the executable
  3. Select “Properties”
  4. Under the Compatibility tab, make sure “Run As Administrator” is ticked
    This allows the software to make changes to things on your PC, such as making and updating save files.

Step Three
Make sure the Metro 2033 game save folder (which, if memory serves correctly, is in My Documents) is not set to “Read Only”.

Step Four

  1. Check the folder mentioned in step three. If there is a save file there, move it somewhere else, such as on your Desktop.
  2. Uninstall the game.
  3. Re-install it.
  4. Move the save file back into the folder mentioned previously.

Thanks, this really helps, and if you wanted to know, I got this from a weekly drop or a humble bundle a little while ago!
thanks for the help!
(I’m currently reinstalling the game)

I did all of the steps to make sure it worked

I learned that running the file as administrator actually makes it unplayable until you UN-check it, so don’t do that.
also, my save file is working now, so no worries!

Ok great glad you finally got it to work

yeah I think I am gonna uninstall it from Epic and reinstall to see if that fixes the issue and yes was past the intro mission have been trying out various chapters but the problem persisted

When i try to download it, it says installation failed, and i can only enter into the setup log or cancel. What do i do?