Outriders Cheats and Trainer for Xbox

No problem, that is what I thought you meant. I also use Game Pass on PC and have no issues on the Xbox side of the coin. I have never even given it any thought. It works regardless of whether I have the cheat file in or the regular one. You may need to get it running the first time since it logs you into Xbox account at game startup, but after that all is fine to switch it up.

it’s not working i try what WilECoyote said but it still not work

Did you pick up the original EasyAntiCheat.exe from the link above to use as a swap out?

If you have ever played the game and the installed EasyAntiCheat.exe got updated then it will no longer work. You will need an updated EasyAntiCheat.exe file to swap back and forth.

it’s work now i just turn off internet > Delete EasyAntiCheat.sys > open game and wait until go to offline lobby > turn on internet and open cheat and it’s Work
btw thank u WileECoyote

1 Like

Yes, when using the cheat there cannot be a .sys file in the EasyAntiCheat directory. I keep only the un-updated EasyAntiCheat.exe in there and move the non-cheat .exe and .sys to a sub directory so I can put them back when I wanna go online for multi-player.

Glad you got it working.

If you want to use the customization menu while the trainer is active, you just need to swap characters before you leave the lobby. I have a second character for this purpose: swap to them, then back to your main character, then start the game like normal and the customization menu will work.

1 Like

the steam version works, the xbox version doesn’t

I think I did something wrong when following @WileECoyote instructions. I have your file backed up and I put it into EC’s folder (without .sys file) with my computer offline, then I launch the game using the icon on desktop but the game replaces the .exe file with another one and creates a .sys file.
There’s no ‘offline’ warning message and I get to the lobby even without internet connection, so I think that EC was updated previously in my first attempts to run WeMod earlier and get my initial character backed up somehow.
When still offline I try to click Play on WeMod but it gives me that error message mentioned by others previously.

If the original file gets updated at some point (you were online when the file was in the main folder) then it is no good. You said you kept the original in a sub-folder then delete everything out and replace with the original one that you got from the link. It should work then. Always make sure you are offline at all times before starting or it will update that .exe and you can’t use it anymore. If you are offline mode and using the correct cheat file it will not create a .sys file at all.

As per I remember as soon as I installed the game I went offline and started it from the desktop icon and it launched Xbox screen so I imagined that I should be online at least for the Xbox login.
After that I went offline again, created the character and tried to launch WeMod, but wasn’t successfull.
The next step was to delete the .sys and tried everything again, but again not working.
Then I downloaded the file you shared, moved both files to a subfolder (the .exe and .sys) and while offline launched the game again but I noticed that it is still creating the .exe (3 times bigger than your file) and the .sys file.
Now I am uninstalling the game and will download/install it again to have a new set of attempts.

I haven’t tried it in awhile. Again, if the .exe is creating a .sys file then it is updating somehow. Any online update will update it to the larger file. If you are completely offline then the .exe should not change at all. If wifi then make sure there isn’t a secondary wifi, if cable then unplug it.

EDIT: I still got it to work as of 5/19/2022 and screen captured it. I am editing the video now (blurring out sensitive info) then will post a youtube link here. Working on it, editing video is incredibly time consuming as I don’t create content and am having to google how to do everything.

Man, I am sorry, I am a complete idiot… It was my mistake: I put my computer on airplane mode thinking that I was offline but I forgot to disconnect/disable the ethernet connection, so the cable was still there and I was still online.
Disconnected the cable (and really went offline) and everything is ok!
Thanks for your patience and support!

Glad you got it working. I had to use a free online tool to make the video, but I was able to include step-by-step instructions for Xbox Game Pass users. It still works (as of 5/19/2022) and here are the links needed:

Original EasyAntiCheat.exe download to use for cheating offline: Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.

YouTube Video with Step-By-Step instructions: WeMod - EasyAntiCheat Bypass - Xbox Game Pass - 5/19/2022 - YouTube

Forgive low editing quality of video. I have never made content before and had to use free online tools to figure it out.

Hopefully this helps!

2 Likes

Xbox version working as of 5/19/2022, I posted an amateur step-by-step video and link to original .exe file to make it work.

2 Likes

okay! thank you, I apologize and I will try again following those instructions

So I did what you said but my wemod keeps just loading and not saying playing

Tested 26/06 having the same issue as @moongazor10, WeMod just stays stuck on loading sadly and never attaches

Tested today with worldslayer update, some cheats still work well, unlimited ammo, no reload,
super accuracy, no recoil, max legendary drop rate

just open the game normal, and start playing, then just open wemod and push play button
and it should work, that work for me

The Outriders cheats have been updated!

Changes:

  • Unlimited World/Apocalypse Tier Exp cheat added