Pillars of Eternity Cheats and Trainer for Steam

Pillars of Eternity
This is the official discussion topic of the Pillars of Eternity Trainer and Cheats in the WeMod app. Please post any suggestions, bug reports, or praise that you may have for the cheats in here!

Download Trainer

Download the trainer or find it in the WeMod app.



Trainer Options and Cheats:

1. Unlimited Health
2. Unlimited Stamina
3. One-Hit Kills
4. Easy Craft
5. Unlimited Items
6. Unlimited Supplies
7. Unlimited Money
8. Unlimited Skill Points
9. Unlimited Ability Points
10. Unlimited Talent Points
11. Add Might
12. Add Constitution
13. Add Dexterity
14. Add Perception
15. Add Intellect
16. Add Resolve
17. Unlimited XP


Screenshot:



Supported Game Versions:

We strive to keep our trainers up to date with the latest game versions. WeMod automatically detects which version you have installed and activates the mods accordingly. So there’s no need to worry about which version of the game you have!



Updates and Changes:

  • 03/21/2018
    Started development

  • 03/21/2018
    Released trainer with 17 cheats



Like what you see?

Check out all of the games WeMod supports here.

3 Likes

does this have controller support?

1 Like

Nope dont look like it. I wont play without a controller. Grew up with consoles

1 Like

Still good game tho.

1 Like

just letting you guys know half the mods dont work on here like the Health, Stam, skill points about the only thing that did work was the Unlimited supplies.

Thanks in Advance

2 Likes

I cannot get the cheat to work either. Not sure why - any suggestions welcome.

2 Likes

Infinity is seeing the pillars of eternity exe as invalid. Have you updated to include the expansions?

1 Like

I’m not clear what “Easy Craft” does or what items are affected by “Unlimited Items.” Trying them out in the game doesn’t work correctly either. In fact, “Easy Craft” breaks the crafting and enchant interfaces badly, and continuing to turn them on and off just caused a crash.

1 Like

I wanted to reply in case anyone is still trying to use this trainer. You must have your inventory open before activating the cheats. I tested this myself and all cheats worked perfect.

1 Like

Right…so I have no idea why, or even remotely how to fix it. Activating Unlimited XP literally kills the character AND gives them a level up. So, I am very very confused on how that even works in the first place. Better part of this is, this never happened to me before. Was the coding changed at all to cause conflicting issues with health and so on? I’d assume not given the last time this was updated it hasn’t changed…seriously confused…

Edit : Redundancies

Right, so as I was going through the codes I found myself seriously wondering on how the codes that add Might, and each respective attribute actually work. When I hit the execute button for the corresponding effect…nothing happened. In addition, Unlimited Talent, AND Ability Point AUTOMATICALLY turn off…which kind of defeats the purpose of turning them on no? If that in itself was not an issue, they do not actually do anything even when triggered. Unlimited Skill Points has to be REtriggered after each level up. No ifs ands or buts about it. Unlimited Experiences only works up to the maximum level cap of the game itself which is by the way 16 and normal play expects you to reach around level 10 to 12 ideally before moving on. Now to the heart of this issue, by no means am I attempting to belittle Stinger for his great work compiling this code together for us; however…you can Mod the game with something called IE Mod on the Nexus community, the instructions of how to do so are right there, and in addition to that can apply most of these effects with close to no real issue, as it even recommends making a back up of your C Sharp folder, which all that really means is putting it into another folder and adding a simple line so if you ever wanted to go back to a basic game it would be fine. This also allows you to use the console commands without disabling achievements.

I sincerely appreciate Stingers efforts in putting this together and truly it does make life substantially easier as well as allow you to explore the game more openly but a more effective method for this particular game exists and I urge others to look into it if you insist on using the Trainer at the very least.

The 2 codes I found myself using despite having access to the Console Commands were the Unlimited Health and Stamina codes, as One Hit Kills gets cheap fast and can easily â– â– â– â–  your play through for a no kills game even by accident.

1 Like

Unlimited Money is not currently working. My game is totally up to date. I’m not sure if there was an update to the game after the trainer was made. I can try CE for it. No biggie.

Aside from that, I’ve only used Unlimited Health and Unlimited Stamina, both working perfectly.

Thank you for your work! :smile:

Actually, it does. Why they don’t list it as a feature I don’t know, but here’s a quick guide: https://steamcommunity.com/sharedfiles/filedetails/?id=1425147544

2 Likes

It worked one time for me. i was able to complete legendary enchantment without meeting the level requirement or with the required material, or the maximum enchantment restriction.
That was yesterday.
But today, it went back to before, after turn on the easy craft, i can’t open the enchant screen, and the craft screen become messed up.

I just downloaded Pillars of Eternity Definitive edition, and I am noticing that none of the cheats are working. Every cheat I tried using did not work in game. I am not sure if there has been updates to the game that causes the trainer to no longer work. I tried the unlimited health and was still taking damage in the first fights in encountered. When I tried to add additional stat attributes nothing happened to my characters stats in game.

I do not know if this is a popular game or if anyone else has noticed this issue. I love your platform and use it on every game that I can. It makes gaming much more enjoyable for me. Thank you for all the hard work you put into every trainer.

It may be possible that the Definitive edition is a whole different game in terms of trainers and may need its own one made.

Does it launch the game when you click play from WeMod?
Does the Cheats active, they just don’t work?

Yes hes correct this is just for the vanilla version of the steam game. Probably would need a new trainer for definitive version.
Did you try it with inventory open ? Open and close ?

Yes I tried it with the inventory open and I was not able to get any of the Stats to increase or change. I was not able to notice any of the cheats in the trainer working.

Unlimited supplies, unlimited money, unlimited talent points and unlimited ability points does not work.

confirming though it shows compatible if you have the DLC it is not had this problem with other trainers and cheats when The White March launched

Easy craft also doesn’t work, and also breaks crafting (unable to craft or enchant). This is fixed by restarting the game it seems.