Pillars of Eternity Cheats and Trainer for Steam

The program was working fine for a while, but options for ability points and talent points stopped working. They deselect after i select them immediately.

Trainer needed for Epic Games version. Epic just gave the Definitive Edition out free.

6 Likes

yeah was just about so that that. though I was more going to say it could use somewhere to request the game

2 Likes

I want to request a 64-bit version for the epic game. Please!

8 Likes

Hi STiNGERR!

Thank you for this trainer.

Unfortunatly, I can’t use it even with the executable path defined. I have the game on Epic Game Store for free in Definitive Edition 64Bits.

Can you please see if you can do a trainer compatible for this one?

Thanks a lot!

7 Likes

@STiNGERR Can you add egs x64 version of this trainer?

1 Like

Not all cheats seem to be working anymore, I’ve only used 2 however.

“Unlimited Health”: Working
“Unlimited Money”: NOT working

Hey there,
Everything is working fine for Steam except Easy Craft mod. When the option is on and I open the crafting window there is only one recipe repeating itslef couple of times. And enchating items button doesnt work. :frowning:

yep, clicking enchant after activating the cheat doesn’t open the enchant window. have to quit and restart the game for it to work again.

other cheats not working for me are unlimited ability and unlimited talent points.
Using most current steam version with both whitemarch DLC.

Doesn’t work on epic games version, says that it is 64 bits version, i’m cracking my head here because i tried 4 different trainers already but none of’em worked

Is this ever getting an update? Please?

Steam Cheats worked for the GOG Version until maybe a month ago.

I have Pillars of Eternity - Definitive Edition for Epic games. These def do not work.

Yeah, I’m having the same Ability / Talent points issues as the others in that they do nothing and turn themselves off. Health seems to work fine, and I believe stamina does too. So did the ones for raising the attribute points, though I notice that the key-bindings are the same as in-game ones, so they do multiple things when pressed…

Funny thing is, this trainer isn’t even listed as out of date in WeMod, though it quite obviously is.

i have the game on epic games, i use the fix for the steam version, but it highlights that it is the 64 bit version, while it requires the 32 bit. How can I solve?

also works well with amazon prime gaming (if you choose steam and use the fix option)

What fix option? I see no such thing.