App Horizon

[RELEASE] Deus Ex Human Revolution Editor


#21

Alright, I found it. I’m gonna see if it works now.

Thanks

Edit: Works fine now.


#22

I will test this editor now(:

I finally thought about getting it for my j-tag


#23

Funny how it sometimes works and sometimes doesn’t. Waiting for a fix!


#24

The updated version can be found here [RELEASE] Deus Ex Human Revolution SE 2011 v3.1


#25

got an error if i try to start… any ideas how to fix? thx…


#26

Thank you so much for the editor. I will be trying this. Question. This does work for the XBox 360 save file right?

I finished the game already on a speed run through. I hate that they don’t give you enough to do get all the augmentations. So the praxis points is what I am after. I want to be able to have fun on this for a run through having all the augmentations from the start. After all it is a one player game not competitive.


#27

ok I think I need some help here. I tried to copy the save files 3 and 4 from xbox but when I put my thumb drive in the computer I don’t find it. The xbox still finds them though so I know they are on there. What am I looking for on the thumb drive? All I see on it are data0000 through data0008 files. I thought I would see a .sav file. Anyone mind helping me figure out what I am missing here?

P.S. This is my first time trying to mod something on xbox so I may be missing alot.


#28

Additional Note: I downloaded explorer360 but it won’t find my thumb drive even though my computer does. I tried using the drivers list in this forum but it won’t go to the proper options, it just looks in the drive without giving me the option to pick the driver to use. Using windows 7 so I think that might be part of the problem.


#29

Super triple post!!!

OT: Use Horizon’s device explorer. That’s how I modified mine.
Note: You need to extract the savegame file out of the savegame file. lol


#30

just tried it, extracted the savegame.sav and well it gave me an error saying the STUF isnt valad or is larger than it is and i never modded this save


#31

nvm i had to load GAMER# and it worked, nice i finally dont have a freezing issue and i dont need to hex the weapons and crap


#32

UPDATE POSTED!


#33

If it uses X360.dll doesn’t it have to be open source?


#34

First thanks to all those who are/have worked on this…

Sorry if I am missing something bit it seems you can only edit the items you currently have? When I DO add more ammo and save the game, write back to the XBox and reload the save it doesnt show any changes at all. Is there something I am maybe doing wrong or is it still not ready for using yet?


#35

I don’t know but I googled it and your post was the only thing I found on it. Also that seems like a r-tarded thing lol. the X360.dll only does a tiny thing in the Editor, why would I release the source for my full Editor??? I will copy/paste the code I used where X360.dll was used, but I’m not posting the full source code. If you have a problem with that then I’ll just remove my Editor…


#36

I just get a error at start-up stating the program encounted an error :anguished:


#37

Make sure you have .net framework 4.0


#38

Can’t seem to get this bad boy to work, once i open my save it says the following: "File size is not on correct sizing bounds or file size is not large enough to be STFS"
Am i doing something wrong?


#39

Game myself a lot of painkillers and energy bars. I am now a ninja in the game.


#40

WHY DOES IT NOT SAVE ANY OF THE CHANGES I MAKE??? everytime I reload the game back to the XBox its just the same as it was before I modded it!!:frowning: