App Horizon

Rise of the Tomb Raider Cheats and Trainer for Steam


Trainer didn’t need update, the only cheat not working was ammo but no reload still was. Please run dx11 version of the game, this trainer doesn’t work for dx12


The Rise of the Tomb Raider cheats have been updated!


  • Bug fixes and game compatibility improvements

Please post in this topic if you run into any issues!


wrong dll error when trying to load


Run the dx11 version of the game


windows 7 doesnt allow directx 12 so its automatically directx 11.


Did you try starting the game first and then attaching Infinity by pressing play to it?
@STN your expertise


Should work fine. Not sure why it doesn’t.

What is your game source/version?


I get the same Error saying “An Error has occurred while loading imports. Wrong DLL Present.”. I will upload a screenshot to follow :).

Loading the game first, then the cheat causes the game to freeze then crash.

The build running is v1.0 build 770.01_64 (shown in screenshot)


Just tried mine and it works vrs. 1.0.770.1
Just so @stn isn’t banging his …head
And I’m also running DX12 too


Is it steam version?


The error pops up as the setup screen loads, iv reinstalled Tomb Raider and wiped Infinity completely and install it again, but same error is it DLC based you think? I don’t have the option for DX 12 as its grayed out, can’t see that as being an issue.
Showing an image of my files inside the directory, hoping it will shed some light?


Is it steam version?




Then i don’t know. @frank any ideas?


Cheers for helping @STN :slight_smile:


i have tried that yes. it says, " An error has ocurred loading imports. wrong Dll present. i have validated the game. reinstalled the game. reinstalled the cheat. nothing works.


Try to disable your antivirus/add infinity to its exception list.


no antivirus on


Well then i have no clue. @frank wrong dll error


Hey guys, sorry for the late reply. I was talking to STN about this, and we are unsure what’s causing the error. Is there anybody who isn’t getting this error?