Sid Meier's Civilization VI Cheats and Trainer for Steam


  • Fast recruiting rejects itself if turned off and on again
    This has also been tested on DX11

Hello MrAntiFun, I really enjoy the Civ 6 trainer that you have created although I do wish it had more features. I wanted to suggest features using the suggestion feature but I don't think it is as effective as letting you know what I would like and where it could easily be found.

Before we begin, make sure to enable the tuner in-game options first before doing all this.

Step 1: Open Sid Meier's Civilization VI Development Tools

Open the "Sid Meier's Civilization VI Development Tools" application on Steam. You can find it in your Steam library by searching for "Civilization VI Development Tools" or by navigating to the "Tools" section of your library and looking for it there.

Development tool location on Steam

Step 2: Access FireTuner

Once you have opened the Development Tools, select the "FireTuner" option. This will open up a Lua console that I did not have much use for in my research but you might if you ever wanted to do something with that. For the purpose of my post though, we just have to skip over it.

Step 3: Open Debug Options

Click on the "File" menu at the top left of the screen, and then select "Open Panel". From there, navigate to your Sid Meier's Civilization VI file and open the "Debug" folder. You should see several different debug options available.

There are a lot more files to choose from, I just wanted to show a couple. It is very hard for me to navigate through this tuner and I wish it was just on WeMod. Also if the options from this were to be added, the host could mess around with their friends. Me and my friends usually hop into a match and use WeMod to do crazy experiments but it is only the host who can use WeMod, with the ability to choose which Civ you want to give anything or promote any unit it opens up a whole new world of gameplay but it could also be bad since people could abuse this in multiplayer games. Ultimately, it would be pretty awesome to have it as an option but you know better than me and I’m not even sure if this helps you in any way at all. Thank you for reading.

On Direct X12: Fast Recruiting doesn’t work.
If that can be fixed, that would be great.

Would it be a possibility to get mods/cheats for things like “spy action garunteed success” or “set era score” ? Also maybe a “set envoys” instead of unlimited envoys?

Bump lol for me it works when i enable it, however if i turn it off then back on it won’t work.

Works fine on DX12, but deactivate unlimited movements before ending your turn, especially if you have a lot of trade route. Else they will go back and forth for a few minutes during which the game will be frozen. You can reactivate it afterward.

The fast production cheats can’t be turned on again once you turn them off once without restarting your game.

1 Like

Fast research and Fast culture results in game freezing.

I’ve uninstalled and reinstalled both the game and Wemod, but when I try to start Civ6 through Wemod it errors and start the game without the mods. {tested on DX12 and 11}

Game Pass version pls, if possible I can gift the Anthology version, thank you for your time.

I everyone, on Civilization VI the DirectX 11 mode doesn’t work ( my game crashes every time)
I use on Epic Game but if I play in DirectX 12 wemod app get me an error and the app crashes (wemod).
Someone have an idea in my isue ?

1 Like

There seems to be an issue with unlimited movement- whenever a trading path goes through any amount of water, if I have unlimited movement on at the end of any turn, it’ll cause the trader to infinitely move on the whole trading path and prevent the game from progressing.

Played the game using DirectX12 via Steam yesterday perfect with no issues, this morning however the game refuses to start and crashes at various points when loading via WeMod.

I get various errors, doesn’t seem to be consistent. Game version is: (918298).

Loading the cheats at the map loading screen (clicking play) makes them take effect (assuming mods are saved), but if you try and turn them off during gameplay it crashes the game.

For reference the following cheats appeared to work fine (these are the only ones I used);

  • Unlimited Gold
  • Fast Research
  • Fast Culture
  • Fast Recruiting
  • Fast Construction
  • Fast Project

One of the error messages;

Unhandled Exception
Error reading address 0x0

Call Stack
??? ! ???   ???, line 0
??? ! ???   ???, line 0
??? ! ???   ???, line 0
??? ! ???   ???, line 0
??? ! ???   ???, line 0
??? ! ???   ???, line 0
??? ! ???   ???, line 0
??? ! ???   ???, line 0
??? ! ???   ???, line 0
??? ! ???   ???, line 0
??? ! ???   ???, line 0
??? ! ???   ???, line 0

For some reason whenever i tried using the mods it just keeps saying loading mods, i tried starting the game then starting the mod but still doesnt work.