App Horizon

Sid Meier's Civilization VI Cheats and Trainer for Steam

This is the official discussion topic of the Sid Meier's Civilization VI Trainer and Cheats in the WeMod app. Please post any suggestions, bug reports, or praise that you may have for the cheats in here!


Download:

Download the trainer and find it in the WeMod app.



Trainer Options and Cheats:

1. Unlimited Gold
2. Unlimited Faith
3. Unlimited Envoy
4. God Mode
5. Unlimited Movement
6. Unlimited Nuclear Weapons
7. Population Minimum 10
8. Set Money
9. Unlimited Resources
10. Fast Research
11. Fast Culture
12. Fast Recruiting
13. Fast Construction
14. Fast Project


Screenshot:



Supported Game Versions:

We strive to keep our trainers up to date with the latest game versions. WeMod automatically detects which version you have installed and activates the mods accordingly. So there’s no need to worry about which version of the game you have!



Updates and Changes:

  • 09/14/2019
    Started development

  • 09/14/2019
    Released trainer with 13 cheats

  • 10/13/2019
    Bug fixes and game compatibility improvements
    Updated notes

  • 12/06/2019
    Set Money cheat added



Like what you see?

Check out all of the games WeMod supports here.

2 Likes

This trainer supports base game, Rise and Fall and Gathering storm , Took a lot of work to put it together , Any issues let me know.

6 Likes

DX12-compatibility please MrAntiFun

3 Likes

Thank you sir. So far, inf. gold, faith, envoy, movement, and god mode aren’t working.
I run on DX11, tried to reactivate and reload the game but still not working. Thanks

1 Like

Thanks for the trainer! It is working well for me with none of the DLC (don’t own it yet). I would definitely be interested in a DX12 version if you ever get the time, I know you are busy creating trainers for basically every game!

Same as [HadiWongso96] , using cGathering storm 1.0.0.341

Unlimited movement does not work, when active a series of movements is maintained and suddenly stops working and units bought in cities while activated do not have this effect

1 Like

Newest version of Gathering Storm: Seems like everything works occasionally, and then it’ll crash at random. Usable though, doesn’t crash too often. As long as I don’t do too many actions too quickly. Truly appreciate the hard work you put into your trainers Mr.Antifun, been a paying member for a few months and definitely won’t stop now. :slight_smile:

Using Production cheat with a captured city causes a CTD

create the DX12 man

1 Like

+1 for dx12.

1 Like

Doesn’t the current trainer work for DX12 if you launch the game first then press play on trainer?.

1 Like

I can’t enable any item.

I am having issues with unlimited gold. when i try to do it, the game crashes. thanks
maybe i am doing something wrong.
i do it in the following order.
open steam.
open wemod.
start civ vi (use direct x 11)
start/load a game and wait until it is finished
switch apps to wemod, select civ vi and click play
return to game
click F1 ( i have tried waiting several turns before this with the same result.
game crashes.

thanks!
J

1 Like

I have the same problem activating unlimited gold.

Same for me, this doesn’t seem to work at all actually on Gathering Storm…

No it doesn’t work with DX12 it keeps saying we’ve a problem…etc i hope u can fix it and thanks

The Sid Meier’s Civilization VI cheats have been updated!

Changes:

  • Bug fixes and game compatibility improvements
  • Updated notes



Please post in this topic if you run into any issues!

Launches the German version of the game for me. Weird.

But now it launches in English…double weird.
don’t know how I fixed it…