Skyrim modding invalid stfs package

I have been looking around trying to find out how to fix the message invalid stfs package i have the mod on my desk top. I have tried to drag but all i get is a circle with the slash in it and when i try to inject the file it says not valid con stfs package! please help!!!

what are you trying to inject? A save?

Yes Have tried to inject it but its says invald con stfs file and it won’t let me drop it and yes its a save

You need to rename the Savegame.ess to Savegame.dat, then re-inject it into the save, rehash & resign.

Is exs same too ess, im horrible with computers so this helping me out alot

No, you are replacing a part of the file not the entire file. I’m not sure exactly what you’re trying to do here. Please clarify what you have and what you want and I’ll try to provide step by step instructions.

I have a file which is a mod for my skyrim for xbox 360 I have my xbox live guy and my skyrim save on a usb and I have tried to rename it but its still giving me the Invalid stfs package if i try to insert but if i try to drag and drop it gives me the cancel symbol, i’m beginning to think its not the right file any help is super awesome

what’s the file name of the save you have that is modded? As i understand you want to replace an existing skyrim save which you have on usb with the modded file.

I renamed it too skyrim.dat and i do want to swap the save with the file

What was the name of the file before you renamed it? Specifically what was the filename extension exs, ess or what?


SkyrimModsMale.exs file name

Just renaming it if it is the entire save will not work. I suspect that’s where you went wrong. The normal skyrim save (not the pc mod downloads from nexus) contains a file within it called savegame.dat. Just renaming the entire save and trying to use it will not work. Rename it back to the original name,e.g., skyrimmodsmale.exs. Then drag and drop the renamed file (it should go now) into Horizon. Package manager should now open. At the top right of package manager is a tab called contents, click on that and the files within the save will be displayed. One of those is savegame.dat. Right click on that and choose extract, and save it to the desktop (nothing special about desktop except you can generally find things there). Next take YOUR skyrim save, that is one assigned to your profile that you want to replace with the modded save. Copy and paste that save to the desktop, drag and drop into Horizon, click on contents, right click on savegame.dat and choose replace (choose the savegame.dat you extracted at first to replace it with). Then rehash/resign and copy to device (your usb). If you’re going to play off the usb you don’t need to copy the save back to the xbox, otherwise you’ll need to copy it to the xbox. This completely ELIMINATES whatever was in your original save and replaces it with the modded save, so if all you wanted was some changes to your save then don’t do this. As always with modding be sure you make backup of your files before you start. If you have additional questions or problems feel free to PM me. Best of luck.

Hey thanks its working, your awesome thanks for the help

how do i rename the .dat?

Right click on the file, select rename, delete the .dat part and replace it with .ess .

It needs to be whatevername.ess to be able to load on Skyrim PC, and it needs Savegame.dat to be able to load on Skyrim 360.

Okay lol i had the same problem with the stfs package a video would be nice on this as the text you posted was confusing im not very tech savvy so i really dont know what im doing i have both saved to my desktop and still after i try to drag the mod file into horizon it says invalid stfs package im not sure whats going on the mod file extension is .esp so i dont know if thats bad or good lol also the green light on skyrim is gone as im not a diamond player if this effects anything id appreciate a heads up thanks and hope you can get back to me

I’m pretty sure the .esp file you are talking about is a mod from a site like nexus.

Those type of files do not work.

The only things you can add to skyrim without a mod chip’d xbox 360 are vanilla savegames and DLCs.

1 Like

So can I not download mods from nexus if so where could I find them because I really want to download some mods for my 360