Starbound Cheats and Trainer for Steam

This is the official discussion topic of the Starbound Trainer and Cheats in the WeMod app. Please post any suggestions, bug reports, or praise that you may have for the cheats in here!


Download the trainer and find it in the WeMod app.

Trainer Options and Cheats:

1. Unlimited Health
2. Unlimited Items
3. Unlimited Pixels
4. No Monsters
5. Unlimited Food
6. Unlimited Energy
7. Unlimited Breath

Important Notes:

Click here to view important information about these cheats.

Launch game through Steam, get in a mission then attach WeMod by clicking Play.


Supported Game Versions:

We strive to keep our trainers up to date with the latest game versions. WeMod automatically detects which version you have installed and activates the mods accordingly. So there’s no need to worry about which version of the game you have!

Updates and Changes:

  • 03/11/2017
    Started development

  • 07/10/2018
    Released trainer with 7 cheats

  • 07/15/2019
    Bug fixes and game compatibility improvements
    Updated notes

Like what you see?

Check out all of the games WeMod supports here.

1 Like

Just tried this one, and it’s causing an access violation and crashing Starbound for me.


which cheat?

1 Like

As soon as I hit “Start Game” it ran for a few seconds then gave me the access violation.


I had the same problem. Infinity suggested it might be antispyware/antimalware interfering but temporarily disabling it didn’t change anything.

also it can be a admin problem, disable AV and run as admin.

Can you post a screenshot? Infinity does nothing when you simply inject it so don’t know why you’re getting a violation.

@LargeBeer What error code?


I believe I got error code 9, was gonna grab a screenshot but for some reason it works fine now. Hmm. Cheers!

1 Like

Not sure why its doing that, game doesn’t have any anticheat so that’s not an issue.

Try attaching the trainer after game has run.

No luck. Started the game, logged in to my character, and yet when I tried to attach Infinity it still crashes. Tested on my laptop as well and it’s crashing there too.

@revor17 We don’t know why its happening, there is nothing infinity is doing that will cause it to crash. I don’t know what to suggest, i always blame AVs so i would suggest perhaps trying this on an AV free environment but i am not sure of that.

I talked to @frank and he said this should hopefully be fixed in v3.

I think I got it fixed. Had to repair/reinstall the microsoft .net package that comes with Starbound. After that I was able to get Infinity to work.

1 Like

Any chance you could post a quick run down on how to do that? Thanks

Go to < steamroot >\Starbound\_CommonRedist\vcredist\2015 and run “vc_redist.x64” (or use the x86 version if you are using a 32 bit Windows installation for some reason).
Select “Repair” and let it finish.
Restart your computer and you should be good to go.

1 Like

Personally this didn’t work for me but I appreciate the help. :slight_smile:

What is the error you;re getting?

It’s the same error as @revor17 was getting.

Uh okay, nvm.

I thought it was something i could fix

1 Like

im getting the same thing. i hope someone can find a fix that works soon.