State of Decay 2: Juggernaut Edition Cheats and Trainer for Xbox

State of Decay 2: Juggernaut Edition
This is the official discussion topic of the State of Decay 2: Juggernaut Edition Trainer and Cheats in the WeMod app. Please post any suggestions, bug reports, or praise that you may have for the cheats in here!

Download Trainer

Download the trainer or find it in the WeMod app.

Trainer Options and Cheats:

1. Unlimited Health
2. Unlimited Stamina
3. No Fatigue
4. Instant Upgrades
5. Unlimited Car Fuel
6. Instant Radio Commands
7. Set Time of Day
8. Unlimited Items
9. Unlimited Resources
10. Unlimited Weight
11. No Recoil
12. No Reload
13. Unlimited Ammo
14. Better Accuracy
15. Unlimited Durability
16. Easy Craft

Important Notes:

Click here to view important information about these cheats.

If WeMod is unable to find your game, start the game and WeMod with admin privileges.


Supported Game Versions:

We strive to keep our trainers up to date with the latest game versions. WeMod automatically detects which version you have installed and activates the mods accordingly. So there’s no need to worry about which version of the game you have!

Updates and Changes:

  • 03/15/2020
    Started development

  • 03/15/2020
    Released trainer with 16 cheats

  • 03/17/2020
    Bug fixes and game compatibility improvements

  • 03/18/2020
    Bug fixes and game compatibility improvements

  • 05/21/2020
    Bug fixes and game compatibility improvements

  • 06/29/2020
    Bug fixes and game compatibility improvements

  • 08/28/2020
    Bug fixes and game compatibility improvements

  • 10/03/2020
    Bug fixes and game compatibility improvements

  • 10/28/2020
    Bug fixes and game compatibility improvements

  • 12/19/2020
    Bug fixes and game compatibility improvements

  • 06/24/2021
    Bug fixes and game compatibility improvements

  • 10/14/2021
    Bug fixes and game compatibility improvements

  • 02/25/2022
    Bug fixes and game compatibility improvements
    Updated notes

  • 05/19/2022
    Bug fixes and game compatibility improvements

Like what you see?

Check out all of the games WeMod supports here.


The State of Decay 2 (Windows Store) cheats have been updated!


  • Released trainer with 16 cheats

Please post in this topic if you run into any issues!

1 Like


can you make it compattible for steam?? please!,please!


Wemod can’t detect the game, says it is not installed. Can’t set custom directory either because windows blocks access to the game’s folder, have to meddle with permissions and really can’t be bothered… any workarounds?

Edit: Even tried to make a desktop shortcut and link to that but didn’t work.


You need to select the correct trainer in WeMod.

It says that it isn’t installed.


Do you have the Windows store version or Steam? Also did you uninstall SOD2 and reinstall? If you didn’t then you still have the normal version of SOD2. There was no way to update without reinstalling it.

Yea, got the Windows Store version, deleted and already downloaded the newest update. I was checking since yesterday to get the new trainer, but as well as @pasc96, the trainer says that I don’t have the game installed.


Yes reinstalled today jugg edition but on wemod app it’s just not there.
Even tried swapping between versions to doublecheck.


I’ve reinstalled the game twice and the app was not able to detect it. I found the executables in the WindowsApps folder but it is not able to be opened through that method. It says there is an error if I try to open it.



man, a steam version would be nice.

Added custom install since I have game downloaded to my D: drive - path to exe = D:\Program Files\ModifiableWindowsApps\StateOfDecay2\StateOfDecay2\Binaries\Win64. When I click on the Play button I get the same message as others about having trouble locating. If I start the game then the trainer will load. As far as I can tell all things are working except Unlimited Ammo. Tried switching weapons, pull different weapon from Inventory, nothing works. They just eat ammo and run out. Running latest version Win10 Pro.

Wemod won’t find the game for me either way…


same thing w everybody, my wemod cant find it via dragging the shortcut or the custom exe


I got it working by finding the correct exe. To find it, open the game and then open task manager. Find the SoD2 process in the list, then right click and Open File Location. Then, drag that executable into WeMod and click play and it should detect it. Regardless, the trainer should be updated so that it detects the correct executable automatically.

ALSO, like bleepthis said, Unlimited Ammo does not work, and I’m assuming that the No Reload option does not work either.


I just tried it No Reload and Unlimited Ammo don’t work.


1 Like

just like everyone else it’s not showing installed for me. re-installed it three times no luck. manually linking the EXE fails or shows that i lack permission. Took all the steps to give myself permission but wemod keeps failing. Every other game i have doesn’t do this. only SOD2

1 Like

Make sure the executable linked in the WeMod desktop app is correct. It’s possible the trainer is looking in the wrong place for the executable.

  1. Run the game
  2. Open Task Manager once you’re on the main menu
  3. Find the game’s process and right-click it
  4. Click Open File Location
  5. Drag that highlighted file to the custom .exe path in WeMod (Press the down arrow next to Play).

Yep. The task manager option doesn’t work as the OFL is grayed out