Warhammer 40,000: Battlesector Cheats and Trainer for Steam

Warhammer 40,000: Battlesector
This is the official discussion topic of the Warhammer 40,000: Battlesector Trainer and Cheats in the WeMod app. Please post any suggestions, bug reports, or praise that you may have for the cheats in here!

Download Trainer

Download the trainer or find it in the WeMod app.



Trainer Options and Cheats:

1. Unlimited Health
2. Unlimited Movement Points
3. Unlimited Action Points
4. Max Momentum
5. Set Game Speed


Screenshot:



Trainer Video:



Supported Game Versions:

We strive to keep our trainers up to date with the latest game versions. WeMod automatically detects which version you have installed and activates the mods accordingly. So there’s no need to worry about which version of the game you have!



Updates and Changes:

  • 07/22/2021
    Started development

  • 07/23/2021
    Released trainer with 5 cheats

  • 11/04/2021
    Bug fixes and game compatibility improvements

  • 12/08/2021
    Bug fixes and game compatibility improvements

  • 04/24/2022
    Bug fixes and game compatibility improvements

  • 05/06/2022
    Bug fixes and game compatibility improvements

  • 05/23/2022
    Bug fixes and game compatibility improvements

  • 09/14/2022
    Bug fixes and game compatibility improvements

  • 12/23/2022
    Bug fixes and game compatibility improvements

  • 01/06/2023
    Bug fixes and game compatibility improvements



Like what you see?

Check out all of the games WeMod supports here.

On sisters - not works trainer

could you include HQ upgrade points please? thanks

3 Likes

+1 to this. Want to skip the upgrade tree.

1 Like

its no work

1 Like

yeah i can agree that nothing is working, unsure as why this is, as there has not been any patches or updates

2 Likes

its no work

Can confirm that the Unlimited Health and the Max Momentum cheats (and probably others) are not working right now using the Steam version of the game (Build ID: 7004882). :frowning: Fingers crossed for a cheat update soon! Thanks in advance, @STiNGERR :slight_smile:

Weird, I quit the game, restarted it, and loaded my saved game and the Unlimited Health cheat is working for me now. All of my units have 999/xxx health. Not sure about the other cheats, but that one is working for me now.

1 Like

Ive tried this a few times, activating cheats both at the start of the game or in the middle of a battle. ive yet to get any to work. ive tried both in skirmishes and in campaign , ive gone thru multiple turns without seeing affects. not sure if im missing somthing, tried even copying the video for it.

This mod is for Campaign only. Right now, this does not currently work for Skirmish or Multiplayer modes. Launch the game from WeMod, and the mod should work for Campaign mode.

This mod only works for all game modes as of 7/28. Try running WeMod as an administrator and then starting the game through WeMod. I was just able to get Campaign to work, as well as a Skirmish match.

So the same issue, but as Ghost0926 stated, its works: Started up via WeMod, doesn’t work, then closed the game, let WeMod keep running, started directly up via Shortcut (Steam), loaded a saved game, then it works!? A bit weird, but I’m sure Stingger wil have it up and running! :smiley:

1 Like

The trainer works perfectly.

You must first launch the game and once in your game in campaign mode click on the button on WeMod

Just tested it, I launched wemod as administrator this time and its working fine finally for me. Tested both as administrator and not as administrator, its only working when set as administrator, which is fine, its just the first mod ive found that has this issue for me.

TLDR run WeMod as administrator has it working in campaign and in skirmishes without any restarts or anything.

Tested on August 28, it has not been working for a few weeks. All cheats are not working.
Be it running as admin or not.

I’m having some trouble getting it to work

unlimited health is not working! can someone update it please?

works absolutely fine for me

what part is tripping you up? maybe i can help?