Weird West Cheats and Trainer for Xbox

update plzzzz

The Weird West cheats have been updated!

Changes:

  • Ignore Ability Cooldown cheat added
  • Money cheat added
  • Nimp Relics cheat added
  • Golden Aces of Spades cheat added
  • Reputation cheat added
  • Durability Never Decrease cheat added
  • Ignore Weapon Crafting Requirement cheat added
  • Jump Gravity cheat added

Here’s the youtube link in the description for those who’s curious: https://www.youtube.com/watch?v=dQw4w9WgXcQ

There was a critical bug with jump gravity, my apology to those who was affected by it hour ago. It is now fixed.

1 Like

Hey thanks for the update, but xbox cheats are not updated only steam cheats.

Yes and I haven’t had the issue again

check the trainer history tab, there should be a new one in there, but doesn’t show up automatically for some reason.

1 Like

yep that worked! Thanks!

Am I the only one having problems with this trainer? I made sure I’m using the most recent wemod update and I’ve even re-installed my game twice but the cheats don’t work right and cause my game to freeze and crash and sometimes the trainer fails to load altogether. I’ve tried only activating one cheat per session to rule out the problem but they all have the same result.

I just went in on most updated version in history. I have Xbox version and still get the warning that it may not work.

And it doesn’t. I just activated the no reload and unlimited ammo…waited a bit and then tried it out. Not working at all.

So it isn’t just you.

It works, eventually.

I just tested it out, launching the game via WeMod and then just enabled/disabled cheats multiple times and reloaded the game. Unlimited ammo worked instantly but needed to reload a couple of times for unlimited HP to work.

I can get some cheats to work eventually but then my game freeze and crash a few minutes after.
No issues with any other of my games crashing when running Wemod.

if you’re experience freeze then it’s probably the Item cheat one. And I noted that you have to disable it when the game freeze, then the game will continue normally. Currently it’s the best solution I can give for item, but if it causes much problem then I will switch back to inferior one that requires at least 2 of the same item to have its effect.

1 Like

People who are getting the Xbox version to ‘eventually’ work…are you restarting the cheat, WeMod, or the game several times?

I cannot get anything to work. It still tells me it likely won’t work, it takes forever to the trainer from WeMod even though it launches the game and turning cheats on and off and waiting doesn’t work.

What exactly are the steps. I wish they would work this out.

Have you tried out other Xbox game on WeMod? There’s some stuff you can try out before contacting our customer support if those still not work.

  • Running WeMod as Admin.
  • Disable Anti-virus.
  • Check trainer tab history and choose the latest one.

Also here’s the exact steps with time in case it didn’t work.

[4-9 6:24:38 PM][I] Calling trainer Setup()…
[4-9 6:26:16 PM][I] Trainer fully initialized.

  1. You run the game, wait till it reach the main menu.
  2. Wait till the WeMod app shows Playing instead of Loading. (Might takes 2 minutes or more like the above)
  3. Activate 1 cheat to ensure the trainer working. In this case Unlimited Rolls.
  4. Load the save file, then wait a few minutes. (Took 1 minutes here in my case)
  5. The character should be able to do lot of rollings while the cooldown is still shown.
    So yes, I do notice there’s the performance issue, will try to fix it somehow. Currently Xbox app is really wonky.
2 Likes

Thanks, I did get it working eventually the other day but only because I tabbed out and noticed the ‘Loading’. I think one of the reasons I was asking for clarity is that the ‘Required Reading’ is not very clear as well as grammatically ‘off’.

‘It might takes up to 2 after enabling a cheat to have its effect.’

Should perhaps change to:

‘It might take up to 2 minutes after loading game through trainer for cheats to be enabled’

With the previous I took that to mean possibly two things:

  1. Wait 2 seconds after enabling a cheat for it to work
  2. It might take restarting the game twice to enable

This problem is mainly due to me not tabbing out of a game to see my WeMod since I use either my phone or tablet to access cheats on my PC. The phone and tablet app don’t tell you if the trainer is loading or activated properly.

1 Like

when i click play , it just stuck at loading for eternity . what can i do about that ?

i got it to work at last , thank u very much : )

cheats work well!!! until I try to travel to another location then the game closes

You need to disable the item cheat when loading location.

sorry I just realized that the same thing happens even if I don’t use wedmod

The Weird West cheats have been updated!

Changes:

  • Bug fixes and game compatibility improvements
  • Updated notes