WeMod App stuck on infinite loading screen

I’ve tried reinstalling, closing all instances in task manager, checking the xFinity app to see if advanced security is on (it’s not), white listed on windows defender and my AV but it keeps getting stuck at the loading screen on startup. I have noticed that whenever I try to open it multiple instances are open but even though I close them the app goes dark and then nothing happens. Also tried running in admin mode.

Hello and welcome to the community! :slight_smile:

That sounds pretty annoying.

Have you checked out this thread? It contains structured steps you can try to follow: I can’t Install WeMod / "There was a error installing the application" - #2 by Ravenfyre.

Note that adding a software to your antivirus after it potentially removed a part of the software doesn’t automatically recover anything that was deleted, so the steps need to be followed in that order.

There are also a couple other things mentioned there to check as well, besides your anti-virus. :tea: