WeMod is not loading the Mods into my Game


I’ve had this problem several times and I particularly noticed it after an update. And yes, I have already done what is suggested → Why is WeMod having issues starting or finding my open game?

I tried 2 games, Planet Crafter and Sons Of the Forest and both gave me this error. Both games were purchased from Steam.

WeMod version 8.13.12 , not the Pro version

Does anyone have an idea what the problem could be?

Hello and welcome to the community. I hope you’re well today! :slight_smile:

The most common cause of this issue is interference from security programs, such as anti-viruses.

It could also be due to an outdated or corrupted version of .NET Framework, which WeMod requires in order to work.

This thread here has some additional troubleshooting steps: "Wemod failed loading the cheats into your game" / "We’re having trouble downloading the cheats" - #2 by Ravenfyre.

If that does not resolve anything:

  1. Attempt to use a trainer in a game until it fails.
  2. Go to your settings by clicking the cog wheel in the top corner.
  3. There is an option in there to download a log. Do so and share it with us here.

Thank you! :slight_smile:

Thank you very much for your help. I just tried WeMod again and NOW it’s working, like i did nothing different.

1 Like


Glad to hear that.

There’s a possibility that it was caused by something preventing the trainers from downloading correctly, which resolved itself.

Enjoy! :slight_smile:

1 Like