WeMod Setup Failing

Good day, fellow users!

I manually updated WeMod and I had this issue,


Also, I cannot open the setup log, so I am not sure what is preventing it from opening. I downloaded the WeMod setup exe, and this happened.

I do have an internet connection while downloading the setup, when I retry it installs normally till 100% but after finishing up this happened.


Also, this happens every time I launch the setup.


Again, I cannot open the setup log, the pop-up just closes.

I have read multiple posts regarding this issue, and I have tried doing what most users did on the other topics, mainly updating my .NET Framework to the latest which is 4.8


I uninstalled WeMod, and I deleted WeMod on my AppData, both on Local, and Roaming

I also turned off Windows AntiVirus, which is my only AntiVirus, I added both the normal WeMod setup and the 8.13.12 manual update to the exclusions, WeMod is fully uninstalled on my PC and no WeMod instances were running and all files regarding WeMod is also deleted, I then restarted my PC, but still to no avail.

I tried doing the instructions and steps by Sir Ravenfyre, but still I am having this problem.

Also, my operating system is Windows 11, and I am using my internet at home.

Sorry to hear this is happening to you!

Firstly, you should be able to check the install logs here:

If you find something related to WeMod in one of the text files, please upload it and we can investigate further.

1 Like

There’s no folder named SquirrelTemp on my Local folder sadly

Same here, exactly. I think the problem is related to the update.
Please let us know if there is a solution !

Is there any update regarding this issue?

i did everything above (i think im really dumb computer wise) and still i cant download wemod i have no clue what anything in the install logs say so i dont know what to do with that
please help

I downloaded WeMod in another laptop to get the WeMod files there, I copied and pasted the Local and Roaming files from the other laptop, I also took the SquirrelTemp folder, when I run the setup.exe I still had the error, but this time I was able to see the setup log and apparently the access to the Local folder of WeMod was denied.

I was able to make WeMod work again, my problem was the access to my folder AppData/Local was denied. I was able to change Administrator Privileges for both the folder AppData and Local, I was running the setup.exe file but it still was not working, but when I run the offline updater 8.13.15.exe file, I was able to run WeMod fine.

1 Like