WeMod Setup Not Working (No Response)

Hey there. So I’ve just bought Sons of the Wild and played a bit, and was curious if I can install mods on SotW. Found a video by a guy, tried to install WeMod but every time I start it after a while it just doesn’t respond anymore.

I tried looking in other threads but nothing is the case, what do I do?

I appreciate any help. :heart:

Hello @Akr3z, I’m seeing here this is the first time you post, so welcome to our community!

Looking through the Forum, I saw that WeMod doesn’t have mods for Sons of the Wild, you can search above (top right corner) and you will see there is no topic from developing SotW mods.

If a MOD exists for the game you play, WeMod will automatically recognize it in most cases. You can also check the list of games that are in development or in the queue. Also, doing the search here on the forum will show you if the game has mods (there will be a developer thread announcing the project).

Best Regards.

My bad, I mistakenly wrote Wild instead of Forest. I meant this: Sons Of The Forest Cheats and Trainers for PC - WeMod

Oh, ok! Can you post a printscreen with the error you are gettin’? I understood your WeMod app is stop responding, can be your Firewall, antivirus or some driver that needs update. To be sure, it is better if you post the print.

You can also check this solution and see if it fits in your case:

Best Regards.

I can’t. The Setup is not responding without any sign of error.
This is all.

Update: I just had to wait until it unfroze. Installing it right now. So for everyone that has the same problem: Have more patience than me lol.