Wemod won't load Just Cause 3 or 4

I have Just Cause 3 and 4 on Steam and I have never been able to get Wemod cheats for those games to load the game, even though it says they are compatible with the versions I have.

Both are legal copies, and I haven’t had trouble with any other games that I recall, though I haven’t played any other steam game using Wemod, just Epic and GoG.

I have Windows 10 version 1903 and Avast Antivirus, with Windows Defender firewall.

I have tried loading the game first, then tabbing to wemod and having it load the cheat there, and it still doesn’t work.

I have uninstalled Wemod, turned off everything, reinstalled it, added exceptions to the various files, and looked in the quarantine files for any stray wemod files, and nothing works. I have also added a custom path to the exe files. I have also used CCleaner to clean up my registry.

All that happens is when I click play, it starts loading, and never does anything else. I have even minimized wemod and come back a while later to find out it is still trying to load the game. It doesn’t even open steam, if I don’t already have steam running.

I do not know if this happens with any other steam game, because I don’t have that many. But, I can’t seem to recall this happening with any non-steam game, and I have recently been playing Pathfinder: Kingmaker from Epic using Wemod and it works perfectly. (as in like 2 days ago)

Hello and welcome to the community. :slight_smile:

Here are some things for you to try:

  • Check your quarantine menu (sometimes also called the virus chest) in your antivirus program to see if a WeMod file is stuck in there, if there is, de-quarantine it. There have been cases of files getting stuck in antivirus quarantines despite exceptions being added.

  • Make sure you have the latest and uncorrupted version of .NET Framework. Even if your PC says you already have it, re-install it anyway: Microsoft .NET Framework 4.8 offline installer for Windows.

  • Make sure the file path to the game’s .exe in WeMod is correct. To do this, click the downwards arrow next to the Play button and manually link the .exe there. By default, the game else is in C\Program Files (x86)\Steam\steamapps\common\GAME_NAME
    If you’re still not sure where the correct .exe is, see the “Custom Path” header in this thread: "Wemod failed loading the cheats into your game" / "We’re having trouble downloading the cheats" - #2 by Ravenfyre.
    Do not use any shortcuts (ie, on your desktop) to link WeMod to the game, these shortcuts are the launcher, not the game .exe.

  • Make sure you are using the most recent trainer version by clicking the History button in the trainer and selecting the most recent one in the list.

  • Uninstall and re-install Steam.

If you’re still having issues, please use the trainer until it fails, then go into your WeMod settings by clicking the cog wheel in the top-right and download the log, then share it here.

Thanks, the only two I hadn’t tried is the .net framework and uninstalling and reinstalling steam.

Just to check, uninstalling the client won’t uninstall any games.

For the log, when I get this particular issue, it doesn’t fail, it just keeps spinning the loading thing, and never actually gives me an error, but I will try if these two don’t help.

Again, thanks.

Most welcome. :slight_smile:

Yes. You’re removing the Steam launching client, not the games themselves.
Your game save locations depends on the specific game, but they’re commonly found in My Documents > My Games. Or in AppData > Local. Or if the specific games make use of the Steam Cloud, the saves are stored online of course.

I just wanted to make sure :slight_smile: Sometimes these companies seem to make the stupidest decisions regarding things like that, so I rather check before than accidentally remove all the games.

Thank you, reinstalling Steam worked.

Though Just Cause 4 did crash when I exited, which it hadn’t before, but that may be unrelated and is a minor annoyance compared to everything else.

Sorry it took me so long to get back, but I found out the hard way that steam doesn’t like steamlibrary being in a different folder on the same drive as the client… so I had to reinstall steam to a completely separate drive, as I didn’t want it in the program files X86 folder (which I am wondering if that was the issue, because it needs administrative permission to change files from that folder)