Assassin's Creed 2 Deluxe Edition Cheats and Trainer for Steam

This is the official discussion topic of the Assassin’s Creed 2 Deluxe Edition Trainer and Cheats.

it crashes before i can load my save file. WHY?!

Attach infinity after game has run.

I am trying to run the trainer but it says I need the 32 bit game to play. I am not very tech savvy so I don’t understand what this means. I bought the game on steam so I don’t know what to do to make it work

This trainer doesn’t work with the Uplay version. The same problem as the AC Brotherhood and AC3 trainer seems to be occurring: even the trainer says “Playing” it doesn’t acknowledge hotkeys and no cheats activate.

From AC Brotherhood:

1 Like

@MasterZoen Just a quick observation. Ubisoft is having issues with computers running the Discord overlay. Turning that off has helped the keyboard and mouse disabled mess.

An example

I don’t use discord and tend to disable any overlays. Occasionally I use Reshade, but not with any of the AC games.

Is the game locking out the inputs when ran without WeMod? If so, that is not an intended behavior. Uplay does not intentionally block the keyboard as an anti-cheat :slight_smile: If WeMod is causing that, try running the game and hitting “Play” in WeMod after the game is fully loaded. Sounds like there may be a wierd HID device installed that is intercepting input before it goes to the OS. You could look in Device Manager under Human Interface Devices and see if if says more than Keyboard and Mouse. If so, disable the weird ones one by one (not uninstall) until it works.

Its because its made for the steam version of the game. Most trainers are made for the steam version. Some may work with uplay and some trainers may not.

1 Like

Well that’s not vary good seeing as the steam version doesn’t work for a lot of people.

Hi - I know this was a while ago - I have the Steam version of AC2, but when I click play it makes the game go through uplay. I cannot get the trainer to work - I have tried running the game starting at wemod, and have tried clicking Play after the game is already running and neither way allows the trainer to start. Am I doing something wrong or is it just no longer compatible? Thanks for the help in the meantime.

Unlimited Throwing Knives is not working. Once activated and tried to attack, the game will crash without any error. Please fix/help.

Where is your copy of the game from? :slightly_smiling_face:

unlimited knives crash (force closes) game when knives are used when active. its saddening, i like unlimited flying stabbity thingies


Replaying this game and this trainer don’t seem to be working well.
Not sure, but the unlimited HP might not be working all the time, but just visually. I mean, I fell and got a message that my HP was pretty low, but I didn’t bothered cause I assume was just a temporary side effect, then while in combat I end up dying to a normal attack. Another time I was able to use medicine, when the game don’t allow you to do so when you HP is actually full.
Also, crashing when I try to use the knives with the cheat on.

Playing the Steam version, btw.

Unlimited Knives is Broken. Crashes the game if you try to throw a knife while its active.

I’m also getting the “unlimited health” that isn’t actually unlimited. The health bar in-game always stays full, but actually your health still drops like normal. Kinda defeats the purpose. I know this is an old game and not top priority for anyone I’m sure, but a fix would be lovely :slight_smile:

Min går ud når jeg aktivere unlimited knives og skal bruge det hvorfor, og jeg har ac 2

Hello. Welcome to the forum. Please use English on here thank you. :+1:

Playing on steam, which opens Ulay launcher.
Knives deff broken. Fix would be nice…but you know voting rules.
Unlim Health seems to work for me but I do get the visual/audio notifications when I hurt myself to badly. Its like the script visually shows full bars but in the background it will go down until one bar is left and freeze that as its minimum value, so technically you never die. So technically Unlim Health :slight_smile:

if i do a quick cheat engine to find the address for knives, could we work something out?