App Horizon

Assassin's Creed Odyssey Cheats and Trainer for Uplay

The fix for your issue is actually to not use the newest trainer at the top of the history list, but the one below it.

I shall give that a whirl…thank you…thank you very much :sunglasses:

no matter what trainer I use, I still can not teleport :frowning:

regardless of the version of trainer used, teleporting does not work… or it does and i end up under the map, that or the game crashes

we’re having trouble starting or finding your opened game
update please

That’s not caused by a trainer, it’s an issue on the user end (yours).
See this thread for troubleshooting: Wemod "We are having trouble downloading cheats"

resource picker not working and yes i have resources to add to, why not make it on option (i.e. max resources) instead of having to deal with the pain of picking

1 Like

Has anyone found any workaround or hotfix for the teleport not working (Uplay version Sunbeam)? I read that Sunbeam isn’t with WeMod anymore so there’s no chance for an official fix.

Right now, all I get when activating the Teleport hotkey (not even actually teleporting anywhere yet, just Numpad 9) is getting transferred somewhere at the bottom of the ocean without being able to move. I’ve tried the Top 10 latest versions of the mod and still nothing.

I was able to get it to work yesterday, just once and it was accidental, but I can’t replicate it again.

Things I’ve tried:

  • Activating (Numpad 9) while in game world.
  • Activating (Numpad 9) while viewing map.
  • Activating (Numpad 9) while viewing map with a selection marker.
  • Activating (Numpad 9) while on the menu screen (Esc).
  • Going high up, then activating (Numpad 9) while in all those other screens listed above.

All these just resulted in me going underwater with nowhere to go and nothing but dark water and a few jellyfish to see. Although, I did notice that I basically stayed in the same location (markers, location icons, etc) stayed the same with just a small change in distance (a few meters avg). Using Ikaros however, will make you go further away from them no matter where you point him.

I was hoping to make another playthrough and the teleport would really help with some of the stuff I’m not looking forward to run through.

1 Like

I think I found a “work-around” for the buggy teleport thingy. Just activate it on the menu screen before you load a save. lol

4 Likes

can confirm the activate at title screen “work-around” does do the trick i activated the teleport on/off function at main menu and loaded a save and teleported works every time tested a few different times but it does work although you may have to wait a few seconds or so for the world to render in after teleporting usually for very far distances for me i had to wait 10-15 seconds for the world to render but it worked every time thanks WTFUser for that find!

1 Like

uplay+ utd health doesn’t work for some reason i die from fire. teleport puts me in the sky then i die from hitting the ground. Is there a new way around this?

Welcome to the community @smudgr. :slight_smile:

This trainer is designed for the Uplay version of the game, not the Uplay+ version. Both versions have differences that require them having separate trainers.

The Uplay+ trainer that you need to be using is here: Assassin's Creed Odyssey (Uplay+) Cheats and Trainer for Uplay. :slight_smile:

ah ok. thank you

@SunBeam why in this trainer you deleted the free cam feature the free cam it’s very helpful please if you add the free cam feature only this because the other it’s working very well

Hello @1221233 and welcome to the community. :slight_smile:

SunBeam, as the title next to their username suggests, is retired from WeMod, so they are very unlikely to see your post here and even more unlikely to update this trainer.
Looking at previous posts in this thread, it looks like the cheat was removed because it never actually worked properly. The game seemed to throw a hissy fit when players used it, judging from what I scraped from a quick skim of this thread.

Nevertheless, if you want to try it, you can select a previous version of the trainer by clicking the “History” button, which is underneath the Play button.

thank you for the reply

The teleport function doesn’t work at all.
As soon as i press the Enable key (NOT the teleport key) my character teleports 7000m outside of the map.
Tried with both No waypoints set, Waypoint set at objective, Waypoint on ground, Waypoint on water, Activating in map, activating while playing, activating in eagle mode.
Every time it just teleports me to the exact same location 7000m out of the map via the Enable key, not the teleport key.

I found a “fix” for that.

i understand that the author of this trainer retired but is it possible to ask MrAntiFun or another author to fix the trainer, I’m having an issue with the Set Resource cheat not working for the tablets.

It should be working fine still
Need to have at least one for it to work.