App Horizon

Assassin's Creed Odyssey Cheats and Trainer for Uplay


many thanks, that did the trick. I wonder why the free camera hotkey and the resources hotkey interfered with each other, which resorted to the game crashing to desktop?. :thinking::thinking:

Thanks again. :smiley:


I’m not too sure either, maybe it’s simply the fact that two different cheats were overlapping eachother at the same time.


Works for me flawlessly.


big update coming next week hopefully things will still work from begining


If the offsets for camera or those used in some of the hook spots don’t change, everything else will work by default :stuck_out_tongue:


Hey SunBeam… Great trainer bro… But maybe u can add Artifact fragments as a resource too ? would be cool to play with a level 6 spear from the beginning :stuck_out_tongue:
btw thanks a lot for the great trainer


Game engine cycles through list of dead cultists and resets fragments to how many you’ve killed. It will not work. Already discussed.


oh… sorry for my foolish post then :frowning:


Awesome trainer. Only thing that needs to be fixed is the resources option, and only the tablets in specific. That one i cannot get it to work. Appreciate all the hard work so far, good job :slight_smile:


Did you read the big list of instructions?

You have 0 Tablets. That’s why. You need at least 1 for the option to work.


I saw it on the listing that u need tablets for it to work. I had 6 tablets but the trainer resets those to 0. Same with the gold, although later on that one worked flawless. Still that thing with the tablets for now.


The trainer doesn’t reset anything to 0. Read the instructions again. Use the slider to increase the amount. You left it at 0 T_T.


I didn’t, i’m not a noob lol :stuck_out_tongue: but 2nd time it did worked so i’m fine for now. Tnx for the help :wink:


There’s no way you can tell me you’ve not pressed a combination of keys that did something in the background. You heard a beep and you thought it was nothing - - “what did I press? ah, never mind” - - then saw your stuff was 0 when you again used the set resource key combination. Maybe that’s what happened? :smiley:


The ancient tablets doesnt work please take a look into it.


You need at least 1 in your inventory before you can add more.


hey i have a problem again with the free camera i can toggle it but as soon as i move the game crashes is anyone else expiriencing the same problem?


Make sure you don’t have at least two hotkeys overlapping. Ctrl+F or Alt+F will, if either is pressed, will activate both functions. Else… if the game has updated, it might be due to that and I’ll check. Please confirm the first part.


nope nothing is overlaping and update will come in 5 mins maybe it was something to do with the last “update” when they put in the new cyclops and the blindman quest dont know for sure


the game has been updated to version 1.07 and the current trainer version needs to be updated as some functions won’t work properly.

thanks for taking time on creating this.