Assassin's Creed Odyssey (Uplay+) Cheats and Trainer for Uplay

Okay thanks for your help. So does that means we can’t get anymore ability points? I’ve tried enabling/disabling but don’t get anymore. I’ve seen other people having more than 2000?

It depends on your level, higher the level, the higher the skill point cap :slightly_smiling_face:

So I was level 40 when I used unlimited ability points now level 60 don’t get anymore from levelling like you said. So what do I do when my level increase? Enable the hack again?

Sorry now I know how to get more skill points. All I have to do use mega xp get to level 99 and get more xp to get more ability points. Thanks for your help.


there is a problem with teleportation

teleportation command not responding

1 Like

Mega XP doesnt seem to work or im just dumb. im playing the game on Uplay+
When i press the key it goes to ON and then back to OFF.
DOes the trainer need update or am i doing something wrong ?.


Could you try launching the game first then alt+tab to WeMod and press Play, see if that changes anything? :slight_smile:
Also are you using any DLCs? They can sometimes cause conflicts with trainers.

I tried the alt+tab thingy and it doesnt work. Yea when you play the game via Uplay+ i think you get all the DLC`s with the game. Everything else works besides the Mega XP


Hi I am also having an issue with the MegaXP mod with the trainer. Is it possible that this can be fixed?


не работает бессмертие при падении с высоты

Hello! Please try to use English in the forum, we do not have any Russian-speaking staff at present.

Death when falling from a height is a scripted game event, there’s nothing a trainer can do about scripted events.

uplay+ utd health doesn’t work for some reason i die from fire. teleport puts me in the sky then i die from hitting the ground. also mega xp doesnt seem to work either

1 Like

is there a reason why im only getting so many ability points? mega xp wont turn on either, well it does then turns back off straight away ?

you have 3 people here telling you mega XP doesn’t work and no response


@sinisterspen- Please don’t post false statements. If you read the previous posts you’ll see there are responses from staff as well as troubleshooting suggestions.

If there’s a potential issue then MAF will look into it when he has the time to do so, he’s a very busy person. This is not the only game in existence, MAF has a lot of trainers. Myself and the other two community moderators are not trainer developers, there’s nothing more we can personally do beyond troubleshooting and collecting information. You just need to learn to be patient and wait for MAF to find the time to investigate.

There are plenty of free games available to download every week while you wait:

1 Like

im not posting a false statement. ive left it for a few days and it still doesnt work. ive tried seeking help through discord and still no one has got back to me.

the thing what happens when i turn mega xp on, its turns of right away. this is for uplay +. ive tried every troubleshoot option, its not working. i wouldnt say it, if it worked?

That was actually a response for the person who posted after you, who did indeed provide a false statement.

As said previously, it will be investigated when the trainer developer has the time. See above.

okay, my bad.

I can confirm mega xp not working


@MrAntiFun i have a request for you can you make a trainer for the uplay version (no uplay+) for the game assassin’s creed odyssey with the same assets you did for the uplay + version please ? :expressionless: :pensive: