[Bug report] Latest update deletes desktop shortcut (and other V6.2.12 issues)

The latest update today (App Changelog) seems to have removed the WeMod shortcut from my desktop. It went missing right after I restarted the program for the update to take effect.

Refreshing the desktop didn’t cause it to pop out of “hiding”.
Can’t say if it’s caused by the update for sure or if my machine is drunk (again).

Anybody else who has this issue, to restore the shortcut to your desktop:

  1. Navigate to C:\Users\YOUR_NAME\AppData\Local\WeMod
  2. Right-click on the WeMod program in that folder
  3. Choose “Send To”
  4. And then “Desktop (create shortcut)”

That’s odd… Nothing was changed related to that. Can anyone else confirm this is happening? Thanks for the report.

1 Like

Yeah, I’ve had nothing but trouble with this new update so far. :confused:

  1. Got “failed to load cheats into your game” error with the game I was hoping to play today.

  2. Deleted and re-installed from scratch in case my update download was corrupted.
    First two installation attempts failed. Third attempt worked.

  3. Same problem as in #1 still persists.

Done all the usual troubleshooting steps. Admin, AV, run game first, etc etc - everything I’ve been telling other people here in the forum to do the last few months, nothing changes.

Is WeMod supposed to be running in 32-bit? I have a 64-bit system and the game I plan on playing is also 64-bit. I don’t think I’ve seen this 32-bit stuff in Task Manager before. And I’ve never seen this yellow WeMod icon in Task Manager before either.


A similar issue was reported in the past here: None of the trainer are working can someone help me please?. The suggested solution given in the last post of that thread didn’t help in my case.

Try switching to the beta channel and relaunch WeMod.


Also, here’s a snapshot of WeMod’s associated processes with no trainers running in TM on my machine:


The yellow WeMod is the auxiliary service found here: C:\Users\USER_NAME\AppData\Local\WeMod\app-6.2.12\resources\app.asar.unpacked\static\unpacked\auxiliary

1 Like

Thank you for the reply. :slight_smile:

Switched to beta channel. Killed and re-launched WeMod. Sadly the issue still occurs. :frowning:


I recognise the auxiliary service, I have it added as an exception in my AV, alongside WeMod.exe and Update.exe.

I’ve also just noticed that when WeMod is running in the background (minimised to system tray), two of those AuxiliaryService.Exe’s are running. :face_with_raised_eyebrow:


Mmmm… I’m guessing the new update changed something with the aux service. Only @frank would know though :laughing:.

1 Like

Maybe. :laughing:
The previous version before today was working flawlessly. Never had any issues with WeMod at all until V6.2.12. Feels weird being on the other side, asking for support instead of giving it :laughing:
Thanks man, I appreciate you trying to help. I guess I’ll just go and … gulp … talk to the other people who apparently live in this house :grimacing: or something for now. :rofl:

1 Like

Which game is causing trouble? We’ll check that out ASAP.

The processes are correct. WeMod runs as 32-bit. There shouldn’t be two aux ones though. Does that happen every time you run the app?

Had a nostalgic urge to replay the Wolfenstein franchise recently. The game I’m having the issue with at the moment is Wolfenstein: The New Order (Wolfenstein: The New Order Cheats and Trainer for Steam). The trainer was working okay for it less than 24 hours ago.

Just tested on another random game on my computer (Prison Architect in this case) and the trainer worked as it’s supposed to.

As for the auxiliary, I did some further digging.
The second one pops up while a game (Wolfenstein: TNO) is running:

And still hangs around after the game is closed:

1 Like

I’m pretty sure the second “process” is normal actually. There should only be one aux process if you go to the Details tab in task manager. Can you confirm?

We’ll check that game out, thank you!


I can confirm that… … there are two in the details tab as well. :scream: :laughing:

Thank you for your time, guys, it’s very appreciated. :slight_smile:

Does the app ask for admin permissions when you hit Play? If it does, that’ll spawn another process.

It does, yes. It always has as far as I can remember as well. :thinking:

Okay, that explains that. If you run Steam as admin that’ll happen. Otherwise, it should never ask to elevate.

1 Like

Just tried launching Wolfenstein TNO with Wemod attached and here are the WeMod processes I’m seeing:


Details tab:


*Note I don’t launch Steam with admin rights therefore no secondary aux service running.


Are any other games causing issues (if you tried others)?

Edit: Please switch to the beta branch to continue testing. I reverted the change on the stable version because there have been a few reports like this.


@User_N4m3 @Ravenfyre do you guys use an AV? (if so, which one?)


Oh, I’m not having any issue with WeMod or trainers after the recent update. I was just trying to help troubleshoot.

Sorry for causing any confusion.

1 Like

I think hes had too much tea. Ravenfyre !

If I remember I think his AV is Avira ?

1 Like

I see! That’s that mystery solved. :+1: :tada:

Not tried any others at the moment. Been a bit of a hectic day, one of those days when you’re already looking forward to bed by lunchtime. :laughing:

On 6.2.14-Beta.0 the failure to load issue still persists for W:TNO on my end. :thinking:

Avast for me.
I have WeMod.exe, Update.exe and AuxiliaryService.Exe added as exceptions. And I also tested with it turned off completely.

No such thing :rofl: :crazy_face: