Command & Conquer: Red Alert 3 - Uprising Cheats and Trainer for Steam

Command  Conquer: Red Alert 3 - Uprising
This is the official discussion topic of the Command & Conquer: Red Alert 3 - Uprising Trainer and Cheats in the WeMod app. Please post any suggestions, bug reports, or praise that you may have for the cheats in here!

Download Trainer

Download the trainer or find it in the WeMod app.



Trainer Options and Cheats:

1. Unlimited Resources
2. Instant Production
3. Instant Secret Protocol
4. Unlimited Power


Screenshot:



Supported Game Versions:

We strive to keep our trainers up to date with the latest game versions. WeMod automatically detects which version you have installed and activates the mods accordingly. So there’s no need to worry about which version of the game you have!



Updates and Changes:

  • 11/03/2019
    Started development

  • 11/03/2019
    Released trainer with 4 cheats



Like what you see?

Check out all of the games WeMod supports here.

1 Like

The Command & Conquer: Red Alert 3 - Uprising cheats have been updated!

Changes:

  • Released trainer with 4 cheats



Please post in this topic if you run into any issues!

thank you so much for the trainer but could you add a god mode? In some missions you start with a limited number of units and do not have a base that makes these cheats useless, it happens in all C&C!

1 Like

Hello, I tried your origin mod. but it does not work. do you have any advise why it is not working?

Mr Anti Fun can you please update the Command & Conquer Red Alert Uprising Cheats because it isn’t working and whenever i turn them on they turn right back off this is a huge problem please fix it :slight_smile:

Where did you get your copy of the game from? Steam? Another store? Cracked?
I replayed this game back in… maybe December 2019 or January 2020 and the trainer worked fine.

Try Launching the game first and waiting on the main menu for a couple of minutes. Then alt+tab to WeMod to press Play.

i tried this but it hasn’t worked
will it work if i use steam

Since this trainer is designed for the Steam version of the game, as the name of it suggests, then yes, you need to use the Steam version of the game.

Hey, i have the same issue with the Game, everytime i try to activate the cheats they toggle back, i tried using them in the campaign and im using the steam version where i bought the game so it isnt cracked, i dont think that the game got patched so the game version should be the newest one and also be the one this trainer is meant to be so im a bit confused on what to do, the trainer for the standard red alert 3 work the only issue i had with both but also with other games, is that wemod doesnt seem to find the game exes and therefore i need to manually ad them, after that starting the game and then alt + tab to wemod to press play seemed to work fine until now, not sure what the issue there is, none of the situations named by the support on this topic do fit with my situation, since i use the steam version and i use the latest version of the game, as far as i know uprising doesnt have an anti cheat that needs to be deactivated and also im not cheating in multiplayer so i dont know what to do

Hello! :slight_smile:

Make sure you have linked the correct .exe to WeMod. I remember one or two C&C games had more than one .exe buried in the game directory - not sure if this was one of them.

To make sure you are using the correct .exe to link the game to WeMod:

  1. Launch the game via Steam. Wait until you are on the main menu.
  2. Launch Task Manager. Locate the game’s process in the list.
  3. Right-click the game’s process, click “Open File Location”.
    • If you see the word “Expand” when right-clicking, you may need to click this first.
  4. The highlighted file in the window that just opened is the .exe that needs to be linked to WeMod.

Where are your games stored? Somewhere else other than the default C:/?

No my games are stored on C but when going to the File Location, it point me to a Data called “ra3ep1_1.0.game” not the exe but i cant put the directory of this file into wemod since it isnt an exe, as far as i know there isnt a second exe in the files

I also tried to run the game via the exe that i have linked with wemod and not directly through steam and the game started just as it should but wemod still didnt work, it does conect with the game and pressing F1 - 4 does make the typical sound but still deactivates the cheat directly after i activated it

Hello and thank you for the update. :slight_smile:

Do you have the regular edition of the game or the Ultimate Collection?

Here’s some things to try:

  1. Launch the game via Steam Launcher.
    Start a campaign or offline skirmish.
    Alt+tab to WeMod and press Play.

  2. Right-click the game’s shortcut. Click properties
    Go to the Compatibility tab.
    Set the compatibility mode to “Windows 7 Service Pack 1” and to run as Administrator.

  3. Do a search on your PC, using its built-in search tools, for the file name: RA3EP1.exe.
    If you find this, try this .exe in WeMod.


Maybe @Veloxia has some other ideas or may be able to take a deeper look.

The RA3EP1.exe is the one i allready used, the only thing i didnt tested until now was the one with the Windows 7 Service Pack 1 but this didnt seem to work either, im using the standard edition as far as i know and also ,maybe this might help, i used other trainers that i found in the internet on this game before and they worked perfektly with sometimes having a ctd but thats nothing new when cheating in a game ^^ also my Game version as far as i could tell is 1.00

add more mod please , need map reveal please sir

1 Like

can you add god mode

1 Like

I know this game is not that popular now but if you have extra time, would you like to add more options to this trainer? For example god mode, quick level up, fast production etc. I appreciate your effort put into this trainer, it works great.

1 Like

Can you add god mode PLEASE? i can’t even pass the first mission in campaign!

1 Like

No work V 1.0.0
can fix pls?

Update? I know its a really old game but can the cheats be updated. Some of them arent as polished like the ones more recently. And for the soviet team, the insta-build is not working as well as for the other factions. The upgrades for the Asian faction isnt as instant as well, for the barracks and the mech barracks. Thanks.

trainer does not detect game within new EA app works with normal red alert 3 but will not detect uprising only says install game and it is i know as i can launch the game