App Horizon

Dragon born dlc fatal crash

#1

I downloaded the dragonborn dlc file , extracted it from horizon to my flash drive , started the game , is says ( loading add ons ) and then it crashed , I tried this 7 times so it is not a random event

Help pls

#2

Please refer to this thread: I need help using Horizon to get Skyrim DLC to work.

#3

Thank you for the link but I have a problem

Mega keeps installing the file into my wrong hard drive so do you have another dragonborn dlc download link?

Thanks for everything

#4

This should work: https://mega.nz/#!fchBXZoC!W-l1mFfvtBtvQlUXTi8hqAhPOVwLQoYyXDAuwArF9Wc.

#5

Extraction came to 99% then it said that the file is corrupt

#6

It did that in the old and the new lino

#7

Ok, here’s another link for the dlc: http://www.zippyshare.com/kill_seth/id9gbajt/dir.html. This site has all dlc for Skyrim and other games as well. Just pick ‘Skyrim English’ then choose your dlc file.

Let me know if this one works. Sorry about the last link, I pulled it from a thread that was pretty old.

#8

little question ; there arre two dragonborn files (0.001 and 0.003 )

do i download both and extract both

thx

#9

i downloaded both of them so whats next

if i click on them it says that the file cannot be opened by windows

i tried to put them in horizon but it said that the files are invalid xbox files

hewlp

#11

I can’t download it due to computer problems

If u can download it and tell me if it works that will be greatly appreciated

#12

(P.s) if u don’t know how to download it off the internet and change it to the Xbox file then here is the link

I am not offending anyone’s skills in Xbox modding I am just trying to help OK?

#13

Thanks for the video, but I’m proficient with modding Xbox files. Here’s a YT video with ALL DLC in the description and the video explains how to use them in Horizon. This should be the final link/video to solve your issue lol. Let me know if this works.

#14

so far so good the files got into horizon and were transfered safely to my flash drive

i deleted skyrim from my xbox due to technical diffuculties but i have a copy of it on a freinds laptop , now it is just a matter of time untill i meet him and get skyrim then see if it worked

thx for helping me this whole week, i have been trying to solve this problem for about 4 months

i will tell you when i get the file

bye for now

#15

No problem! Hope all goes well.

#16

Please read till the end

So the file failed but I have normal skyrim and I have spent 2 months without it and there was no point playing on my Xbox without it since I have completed all the Gamez on it , it has gotten to the point were the console and controllers were grey due to dust , since I got skyrim back I am happy

If u still want to help then OK , but if you got tiredf rom finding files then it is okay I am happy with PR without the dragonborn dlc

The for all ur help

#17

PS : if u still wanna help then I have some lore for you

I put the file ( the one that’s extracted from horizon) on the USB only , skyrim failed to load on both the USB and the hard drive , but then I removed my flash drive and the game worked fine

Thhxfor it help

#18

Update : so I found this guy https://youtu.be/rgf5UI2Jv9M

And if u do down to the comments the first comment u will see is a guy explaining the steps more precisely as well as some problems and how to fix them , the comment is only a couple of months ago so this is working In 2019, but I have a bad internet connection at the moment so can u do it

Thx

#19

I checked out the video, but didn’t see a comment from a few months ago. I sorted the comments by newest first and the most recent comment is from 2 years ago. Is this the correct video?

I’ll test it out for you, but I’ll need the video and instructions you’ll be following as well so we have consistency.

EDIT: This video is from 2015 but has been proven to work in 2019 with recent comments no older than a month: https://www.youtube.com/watch?v=LYQR2a4o_Kc.

Let me know if this works.

#20

Hello. Sorry for not popping in and trying to help sooner.

The problem witht the 2 files from the zippyshare site is that it’s missing file number 002. I’ve used files for all DRM free stuff from there before and now some are missing as they must have been removed.

I just downloaded and extracted the one from the link @User_N4m3 left 13 days ago and it extracted without issue and un-corrupted. That is a link from an old member from here by the name of _Sean. I’ve also used it in the past and it always worked. This one: https://mega.nz/#!fchBXZoC!W-l1mFfvtBtvQlUXTi8hqAhPOVwLQoYyXDAuwArF9Wc

It could be a title update that is giving you issues. I will be honest, I didn’t read every comment here as I’m super busy these days but I’ve helped many people years back get Skyrim up and running with all the DRM free DLC that can be found in the Mega links in this topic with the proper title update.

_Seans Skyrim DRM free DLC topic: | Skyrim DLC | DRM Free |

Just make sure you have the English version of the game, all 3 DRM free DLC files from that topic and the proper title update. The proper title update will be one of the latest ones to match your game ID or whatever it’s called. Sorry but it’s been a while and my mind is not super fresh about this at the moment. Good luck!

1 Like
#22

Also another question : I know that I can use aurora to see the latest title update BUT my console is JTAG and I fear that if I connect to the internet the Xbox live community might read me as if I am a hacker and that they will shutdown the xbox along with my tv ( yep you heard it right I never played online on the Xbox before and I had it since 2014)

So can I see the title update on aurora WITHOUT making an online account