App Horizon

Far Cry New Dawn Cheats and Trainer for Uplay

#42

First use medkit then activate ?

#43

No, activate it first then use a medkit.

#44

The Far Cry New Dawn cheats have been updated!

Changes:

  • Mega Reward Multiplier cheat added



Please post in this topic if you run into any issues!

1 Like
#45

The Far Cry New Dawn cheats have been updated!

Changes:

  • Bug fixes and game compatibility improvements



Please post in this topic if you run into any issues!

2 Likes
#46

Hello, I keep getting the “We’re having trouble loading cheats into the game” error. I’ve tried both the Steam and Uplay versions. This happens with Far Cry 5 too, although that game is marked as possibly incompatible anyway. Am I doing something wrong?

#47

This game doesn’t have any anti cheat, so you should be able to start it manually and then ALT-Tab and select play in the WeMod app!

#48

Seems to be working now, gracias. I know this is off topic but will there be any future updates to the FC5 trainer?

#49

It’s never out of the question, it isn’t a high priority due to it being an older game now with a newer release in the series. If it’s voted for it will be made for sure, extra options will most likely never be added though :slightly_smiling_face:

#50

Hi, I’m running the current version for New Dawn with the latest version of WeMod (did not start the game since WeMod has been updated, though. Now the trainer will not activate, the “play” button is always spinning.
What I tried so far:

  • start uplay, start the game, alt-tab out, then press “play” in wemod
  • start wemod, press “play” (game starts, but the trainer does not activate)
  • do the above with uplay / wemod started with elevated privileges (administrator)
  • pick the game exe directly in wemod.
    It used to work with the old version, my game version is shown as compatible
    Any ideas?
#51

I’ve just tested on my end and it’s still working perfectly. I would quit the WeMod app from the system tray and then re-launch it and see if that helps :slightly_smiling_face:

1 Like
#52

How does Easy Upgrade work? I turn it on but nothing seems to be happening.

BTW, Awesome tool guys!

Thanks!

#53

Ok, found it. somehow I had two versions of wemod installed, the new one & an older version. After I uninstalled both and made a clean install of the current one, it worked. Thanks for looking into this!

1 Like
#54

Easy upgrade is used for upgrading your base and weapons, just makes the upgrades cost nothing :slightly_smiling_face:

#55

I don’t think it’s working. It cost me a f**kton of resources to upgrade my weapons even with that on.

#56

I may have gotten easy crafting a little mixed in, try that option for upgrading weapons, my apologies :slightly_smiling_face:

#57

it dosnt work for me al it dos is a anoying loud iiiiiiiiiiii sound when i activate a mod until i de activate it then it disapears is there somthing i can do to let it work?