State of Decay 2: Juggernaut Edition Cheats and Trainer for Xbox

Its weird… launching from wemod will open the game for me but not actually start the trainer same as the others here. I also just started having this issue today. Played it yesterday just fine. @SenpaiUnique sharing how you fixed it yourself instead of just stating “i fixed it” would probably help alot of people here having this problem and also relieve some stress on the devs as they already have alot of games to manage

I’m experiencing the same issue as Fyb3r0p7ik above. Wemod launches the game for me but the mods just stay “Loading” and it eventually says it can’t find the game. If anyone has a fix it’d be extremely appreciated.

i fixed mine by finding it in the windows menu then launching the game as administrator then when it loads press play on the mods and it loads fine

1 Like

Thanks so much, this is the fix for Game Pass version that we’ve all been looking for!

Pin both SOD2 and WeMod to your Start bar and run both as admin, worked for me.

2 Likes

so i recenly try xbox pass pc end start play state of decay 2 juggernaut edition end then i try to use wemod and use the xbox version but i get some error that say we have a problem starting or finding your opened game.
Note :

  1. when i play from wemod the game was opened but still show the same error
  2. i already try to manualy chosee the exe game in ModifiableWindowsApps/stateofdecay2/stateofdecay2/binaries/win64/stateofdecay2-win64-shipping.exe
  3. i already try to exculde wemod from AV
  4. my friend face same problem while using xbox pass pc

so can any one help me solve this problem or have other solution?
thanks

1 Like

Try running the game and WeMod as admin. It has fixed the issue for a few people.

1 Like

I too am having this issue. I have set WeMod to run as admin but with the Xbox app version SoD2 I can not find the .exe file anywhere.

Funny enough… when launching SOD2 as an admin is tells me “unable to initialize windows gaming service” and will not let me to the main menu. Anybody run into this? NOTE: if i launch it without admin it will work fine but then cheats will not load

I hate windows store ■■■■ they make it so hard to do what you want with the things you have paid money for. After messing with security permissions i have found this. If i fix the SOD2 folder through windows, (meaning the “Trusted agent” has full control over the file) i dont have the permissions to run the game as administrator. If i go in and give myself full control of the SOD2 folder, it will let me run as admin but it wont initialize the windows gaming service at the splash screen and will not let me play at all

So i figured it out… its very weird i believe it has to do with the execution of the game and what file path it uses possibly but if i find the exe in file explorer and try to run that as admin it gives me the problems i have in the post above. if i just search for the app from the start menu and run as admin from there it worked fine. would love some clarification on why this happens if anybody has more experience with this

Running WeMod and the game as admin, then click Play is a work around that I found worked for myself.

I enabled Admin on both WeMod and SoD2 after taking ownership of the windowsapp folder. I still get the error it is having trouble starting or finding the game. The game starts up just fine with WeMod, the trainer just doesn’t activate. I tried to use an external cheat menu by the same author but the game just crashes instantly when I attempt to fire a gun.

You shouldn’t need to take ownership. Search for the game in the start menu then just right-click and run as admin. There is a fix coming for it soon so it doesn’t need to be run as admin.

@putzeh @GetTheClicker @Fyb3r0p7ik @jambanterbang @mattwill93 @Yarnie511 @mattwill93 @VividGoldfish996 @Gawiner @Savage_Razor @MarvelousCake52 @VaultGeekz @SenpaiUnique @hagamablabla

Can you guys try switching to the beta channel in WeMod and then try without running the game as admin? Windows changed some stuff with file paths. There is a new update in beta that should fix it.

1 Like

Beta worked for me without admin

1 Like

beta channel has it working

Did not need to run either wemod or game as admin.

1 Like

WeMod won’t run mods in-game unless I start the game as an administrator and press “Play” while the game is running. Which then causes my PTT in the Xbox game bar to not work. I am running the game from Xbox game pass.

Please switch to the beta channel in WeMod as this has a fix.

Tested Beta Branch, the ammo is not working correctly, even if you attempt to reload, if you have some ammo in inventory, it adds 10 to the clip (I had 2 rounds in inventory), but also consumes what you had in inventory.

Switching to the beta branch is not a fix for the broken cheats.

Yeah sorry about the confusion, hadn’t realized the topic had driffed this far off topic.