Wargame: Red Dragon Cheats and Trainer for Epic Games

Wargame: Red Dragon
This is the official discussion topic of the Wargame: Red Dragon Trainer and Cheats in the WeMod app. Please post any suggestions, bug reports, or praise that you may have for the cheats in here!

Download Trainer

Download the trainer or find it in the WeMod app.



Trainer Options and Cheats:

1. Unlimited Deployment Points
2. Unlimited Fuel
3. Unlimited Ammo
4. Always Calm
5. Unlimited Reinforcements
6. Unlimited Base Resources
7. God Mode


Important Notes:

Click here to view important information about these cheats.

The Play button must be pressed before entering combat. If you try to activate the trainer mid-game, it won’t work properly.



Screenshot:



Supported Game Versions:

We strive to keep our trainers up to date with the latest game versions. WeMod automatically detects which version you have installed and activates the mods accordingly. So there’s no need to worry about which version of the game you have!



Updates and Changes:

  • 03/04/2021
    Started development

  • 03/04/2021
    Released trainer with 7 cheats

  • 06/06/2021
    Bug fixes and game compatibility improvements



Like what you see?

Check out all of the games WeMod supports here.

1 Like

The Wargame: Red Dragon cheats have been updated!

Changes:

  • Released trainer with 7 cheats



Please post in this topic if you run into any issues!

2 Likes

Hello, if i try to press the “Play” Button the app shows me a text “We’re having trouble downloading the cheats. Please try again later”
What can i do?

the version for Epic Games does not work.
when I start it from WeMod it loads indefinitely before I can use the trainers.
when I activate them in the main menu they don’t work when I start the game, even tried nothing during the game.
it shows that they are active but in reality they are not.
how do you use them ??
your trainers have always worked, but this hasn’t.
thank you very much

4 Likes

@Mister1990 & @Dr_DeLaCroix

Make sure you are reading the Info tab in the trainer and correctly following the instructions. This trainer requires you to follow special steps for it to work correctly.

Hello cheat start crashing game after 4h im following your instructions but it still crashing :confused:

Crashes are the result of hardware issues or in-game bugs.

For example, overheating, not meeting GPU requirements, not meeting RAM requirements, etc.

It can also be caused by a by or corrupted download, which is usually fixed by verifying the fame files via the Epic launcher.

Because there are dozens of causes of crashes, it’s rather unreasonable jump to assumptions and point the finger right away at WeMod, which is the least likely cause.

Hello Ravenfyre,
I’m reading the Info - it says i have to press the play button before entering the combat - but the trainer didnt even start in every situation its just saying “We’re having trouble downloading the cheats.” What does it mean?

Any chance to use trainer in campaign? Works perfect in skirmish.
Epic game version user here.

Is there a way to use unlimited ammo without bugging out the planes? because for some reason when i use it the planes wont resupply when sent back to base.

Welcome to the community @DesiredScrew452. :slight_smile:

Could you try deactivating the cheat when you don’t actually need to use it? (Ie, when sending planes back).

yes I’ve been doing that its just a little tedious. I just wondered if anyone had found a way around it.

Is there a chance for unlimited Political Points? It’d come in handy. Tried changing them with CheatEngine but game switches back to previous value right away.

Is the Epic Games version of the trainer broken? I have absolutely no idea how to get this working…

no its not broken you just have to be in a match for it to start working.

How about the campaign ?

Read the info in the trainer by clicking the Info button. It explains clearly how to get the trainer to work. :slight_smile:

1 Like

You have to hit WeMod’s play button before getting into battle, and then just leave it on. Or just start the game via WeMod.

yea the campaign works too but you also have to be in a match before turning it on.

Okay, It took a while after pressing play but it works, I was just hella impatient lmao…