Warhammer 40,000: Battlesector Cheats and Trainer for Steam

I wonder if this works on gamepass?

The Warhammer 40,000: Battlesector cheats have been updated!

Changes:

  • Bug fixes and game compatibility improvements
1 Like

Hi
am I the only one here where the cheats in the campaign work only for the enemy and not for me? xd

Mission 7?

1 Like

We are still waiting on a save from someone on mission 7 that does not use any DLC or add-ons. Unless that is provided, the trainer will not be updated.

I posted a file in reply to you. Just before mission 7’s briefing.

That file is using add-ons according to the game, so it is of no use to us.

Same issue here, up until mission 7 in the campaign mods work. Mission 7 the mods are applied to the enemy, not my units. Maybe it’s because they go first this time? I have all the DLC, but no other add-ons. Won’t let me upload the save because it says it’s not an authorized file type.

Tried loading when it was my turn and then turning WeMod on; same issue. Tried making a new game, but there are no options to turn DLC off that I could find.

yes

Looking to add a save file for this, no add-ons that I am aware of or DLC. Not able to as new user…

Hi Chris, I have a file but not the permission to load here. Let me know if I can send along another way?

Hello, here I leave a zip with two saves, the one before entering the mission 7 and another one with the first enemy turn (tyranid) finished inside the mission. I have the game without any extra, is only the base, on Steam. I hope it helps to fix the problem.
Saves.zip (15.6 KB)

2 Likes

I have noticed a problem in the trainer. The Trainer functions well up to the mission Place of Challenge. What I’m seeing is the Tyranids get the first move and because of this they are getting the buffs. Their units have unlimited health. Is it possible to get this fixed? Thank you so much for all your work.

1 Like

and even after starting the mission with all of it off, then turning them on during my turn, they still do not work.

I have the base game and I have the same problem than everyone (cheat doesn’t work for mission 7).
Do you need more saves ?
Realy hope that you could find the bug as we could purge the xenos again !

November 21st still the same issue, Place of Challenge, all the cheats apply to the enemy and not the player

1 Like

Hi Guys
Same issue still persits. Any chance of fix?

1 Like

And I would love to upload saves (i got only base game with no add-on nor DLC’s) but apparently I am new user…

The campaign missions with AI starting first benefit from the trainer instead of the player. Could a second set of scripts for player_2 be added for these cases?