App Horizon

WeMod not working with Steam Games

A recent issue that has occurred.
In the last few days, WeMod has failed to activate any trainers that relate to games on Steam. Sometimes the program will activate the Steam game (but not always), the game loads but the little play symbol continues to circle until it says unable to detect your game.
Sometimes the game won’t even start via WeMod.
I have uninstalled and reinstalled the program, downloaded the individual trainers, turned off my firewall and nothing seems to help.
I’m only noticing this issue with my Steam games, my Origin games are all loading and trainers are running no problem.

Potentially a Steam issue? Anyone know a work around?
Thanks.

Hello and welcome to the WeMod community. :slight_smile:

Sorry to hear that you’re having an issue with Steam games on WeMod. I’ll try to help. Before you try the troubleshooting below, first restart your PC. Some weird issues are resolved by a simple PC restart.

Also, make sure your games are legitimately purchased from Steam. Cracked or pirated games are largely incompatible with third-party software such as trainers. There is no fix for this.


1) Custom Path

Click here for Custom Path troubleshooting

First of all, set a custom path to the game’s executable on your PC by clicking the down arrow next to the Play button in the WeMod desktop app.

  • The default directory for Steam games is C:\Program Files (x86)\Steam\steamapps\common\{Game name}.
  • Alternatively, you can also find the directory by running the game, opening task manager and then right-clicking the game’s process and choosing “Open File Location”.
  • Note that any shortcuts on your desktop are likely a stand-alone launcher, not the executable.

2) Launch Order

Click here for launch order troubleshooting

Some games work best with WeMod if they aren’t launched via the Play button.

  1. Launch the game first. Wait until you are on the main menu.
  2. Alt+Tab to WeMod. Press Play.
  3. Alt+tab back to the game.

Don’t sit and stare at the WeMod Play button spinning around. I’ve noticed this seems to slow down the process with some games, most recently with Fallout Shelter on Steam. Go straight back to the game after pressing Play and give it about a minute.


3) Anti-virus Interference

Click here for Anti-virus interference troubleshooting

It’s possible that your antivirus has intercepted and deleted a critical WeMod file. Simply whitelisting WeMod or disabling the program after this fact won’t replace this deleted file.

  1. Remove WeMod from your computer if you haven’t already, using the Add Or Remove Programs tool, which comes with all Windows PCs (use the search feature in the Start menu to find it).
  2. Turn off your antivirus software. Even if it’s the default Windows Defender.
  3. Download the installer from https://api.wemod.com/client/download and install the software.
  4. Add WeMod as an exception in your antivirus before you launch it. Log back in using “Switch User” after clicking the down arrow in the top-right.

4) Beta Channel

Click here for Beta Channel troubleshooting
  1. Press the down arrow in the top-right of WeMod.
  2. Go to Settings.
  3. Under the Release Channel heading, select Beta from the options.
  4. Launch Task Manager. Find WeMod, right-click it and select End Task.
  5. Re-Launch WeMod and try the trainer again.

5) Additional

Click here for Additional troubleshooting

If you have either of these, there are additional steps:

  • Comcast / Xfinity - click for instructions .
  • BitDefender - click for instructions .
  • A school/college/university internet connection - use a VPN, there is an extra antivirus program on the school network that you have no control over. Try Opera Browser, which has a VPN built into it.

Hopefully one of these helps.

If all of these steps do not work, please go to your WeMod settings. At the bottom is a “Save Log” option. Save the log in a .txt file on your PC and upload it in a reply to this thread by clicking the upload button on the toolbar.

I’ve attempted all of the above steps, including using a VPN, however, I cannot upload a Save Log because I am a new user.

When using my VPN a few of the Steam games will load and the cheats run, but not all of them. I’ve been trying to add WeMod as an exception to my firewall but can’t seem to find the directory, even following guidance. Is the file under a name other than WeMod?

The files you need to whitelist are in your user’s Appdata folder which is hidden by default. You will need to allow these files/folders to be seen by checking the box off in file explorer:

.

The 3 main files you want to whitelist are:

  • C:\Users\YOURUSER\AppData\Local\WeMod\Update.exe
  • C:\Users\YOURUSER\AppData\Local\WeMod\WeMod.exe
  • C:\Users\YOURUSER\AppData\Local\WeMod\app-x.x.xx\resources\app.asar.unpacked\static\unpacked\auxiliary\WeModAuxiliaryService.exe

Hope this helps :slight_smile:

2 Likes

Thank you @User_N4m3. :smiley: :+1:

If the above post didn’t resolve the issue, the forum system bumped you up to the next user level, so you should be able to upload files now. :slight_smile:

2 Likes

WeMod Borderlands.log (23.8 KB)

Unfortunately no Joy. I’ve whitelisted all recommended files and have my firewall turned off and its still saying we can’t start or find your open game. Strange this has happened all of a sudden.

Have you checked windows defender to see if it is auto flagging the trainer DLL file? I’ve seen it a few times including my own PC but it’s not everyone so it’s hard to track down

I can’t find anything to suggest the DLL files are being flagged, altered or deleted in anyway.
Thanks for the suggestion though.

So aside from Anti cheat, the only other thing that would stop our trainer from injecting would be a process/dll getting flagged and removed.

@Ravenfyre brought up a valid point as well, are you on the latest windows update?

Yeah, I’m up to date with Windows.
I don’t understand why it’s only occuring in some games and not all of them. All of the games and trainers have worked previously and I’ve had no warnings, popups etc to say there’s anything wrong or anything suspicious. Very annoying.

Same thing is happening with mine all of a sudden. Even if I drag and drop the .exe it does not work. Tried reinstalling WeMod, running as Admin, etc…

Same, probably to do with the recent steam update. No man’s sky about half the options work, half don’t.

I was wondering if it was a conflicting Steam update.
I’ve done all the checks recommended by mods and admin, I’ve checked DLL files several times and the mods still aren’t working.

Hello again! :slight_smile:

To be honest I’m not too sure what’s going on myself. I’ve tested this with Steam games (including Fallout Shelter, which I can see you’ve tried via the log you posted) and, no matter what I’ve tried, I can’t trigger the issue you’re having. :thinking:

What games, in particular, are you having these issues with currently?


@gleamingthecube - No Man’s Sky is currently in need of an update, which is why you’re having issues with that particular trainer. See here: No Man's Sky Cheats and Trainer for Steam

Borderlands 2, Deus Ex: Mankind Divided, Occasionally Frostpunk, Judgment: Apocalypse Survival Simulation, Two Point Hospital and Stellaris (which is currently under maybe compatible.)

I haven’t tried out all my games but out of 36, these are the ones I know definitely aren’t being detected.

Man, why is it always games that I don’t have? :laughing:

However, for Borderlands 2 in particular - I’ve read a few posts before that seems to indicate that the game’s exe is pretty elusive and a few people have linked the wrong file into the trainer. See this post here and make sure the correct .exe is linked in the trainer: Borderlands 2 Cheats and Trainer for Steam. If you’re having difficulty locating the correct .exe, launch the game and then open task manager. Right-click the game’s process and then click Open File Location. The correct .exe should be highlighted.


In any event, maybe you could try re-installing Steam, if you haven’t already.

And then verify the game files via your Steam library (click for help if needed), just in case your antivirus previously deleted something. It shouldn’t have done but there are weird and uncommon cases where an AV has.

1 Like

Yeah, already reinstalled and checked the integrity of the games with no change.

@frank Any ideas on this?

I have no other suggestions aside from what was already recommended.

@RegularDonkey98 Can you post another app log from after WeMod says the game couldn’t be detected? Hopefully that’ll give some insight. Thanks :slight_smile:

WeMod Judgment.log (21.3 KB) WeMod Two Point.log (21.7 KB)

@frank Here, I’ll treat you to two logs! Enjoy!